summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-05-21 13:46:37 +0000
committerRémi Cardona <remi@gentoo.org>2008-05-21 13:46:37 +0000
commit79f2284940e08a4e621e9584cf741ae3d37a036a (patch)
tree35c0def85af9367cad99244de7f61893798ccd43 /dev-libs/libsigc++
parentUpdated extensions-patch to version 62. Fixed installing docs. Add DVBDIR to ... (diff)
downloadgentoo-2-79f2284940e08a4e621e9584cf741ae3d37a036a.tar.gz
gentoo-2-79f2284940e08a4e621e9584cf741ae3d37a036a.tar.bz2
gentoo-2-79f2284940e08a4e621e9584cf741ae3d37a036a.zip
dev-libs/libsigc++: Bump to slot 1.2 to 1.2.7, rework ebuild completely and fix bug #219041 in the process
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-libs/libsigc++')
-rw-r--r--dev-libs/libsigc++/ChangeLog8
-rw-r--r--dev-libs/libsigc++/libsigc++-1.2.7.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index cbec04103118..4f1c285b98c6 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libsigc++
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.116 2008/04/20 22:51:16 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.117 2008/05/21 13:46:37 remi Exp $
+
+*libsigc++-1.2.7 (21 May 2008)
+
+ 21 May 2008; Rémi Cardona <remi@gentoo.org> +libsigc++-1.2.7.ebuild:
+ Bump to slot 1.2 to 1.2.7, rework ebuild completely and fix bug #219041 in
+ the process
20 Apr 2008; Ryan Hill <dirtyepic@gentoo.org>
+files/libsigc++-1.0.4-gcc43.patch, libsigc++-1.0.4-r3.ebuild:
diff --git a/dev-libs/libsigc++/libsigc++-1.2.7.ebuild b/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
new file mode 100644
index 000000000000..0527ae0da587
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.7.ebuild,v 1.1 2008/05/21 13:46:37 remi Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.7"
+
+inherit autotools gnome2
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=""
+
+DOCS="AUTHORS ChangeLog FEATURES IDEAS README INSTALL NEWS TODO"
+
+pkg_config() {
+ use debug \
+ && G2CONF="--enable-debug=yes" \
+ || G2CONF="--enable-debug=no"
+
+ G2CONF="${G2CONF} --enable-maintainer-mode --enable-threads"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fixes bug #219041
+ sed -e 's:ACLOCAL_AMFLAGS = -I $(srcdir)/scripts:ACLOCAL_AMFLAGS = -I scripts:' \
+ -i Makefile.{in,am}
+
+ eautoreconf
+}