summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-06-02 17:22:06 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-06-02 17:22:06 +0000
commit6adcdef7d5a96f359c40eab3af8a21a26732a676 (patch)
tree3a9763278a0c012c24715e1dd9425b435345f3b7 /dev-libs/libstrl
parentBump to 3.0.2, updated translations, remove old (diff)
downloadgentoo-2-6adcdef7d5a96f359c40eab3af8a21a26732a676.tar.gz
gentoo-2-6adcdef7d5a96f359c40eab3af8a21a26732a676.tar.bz2
gentoo-2-6adcdef7d5a96f359c40eab3af8a21a26732a676.zip
Bump to libstrl-0.4, which now installs docs into /usr/share/doc/ properly.
(Portage version: 2.2.0_alpha34-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libstrl')
-rw-r--r--dev-libs/libstrl/ChangeLog8
-rw-r--r--dev-libs/libstrl/libstrl-0.4.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-libs/libstrl/ChangeLog b/dev-libs/libstrl/ChangeLog
index 934db27a161c..1d928061d015 100644
--- a/dev-libs/libstrl/ChangeLog
+++ b/dev-libs/libstrl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libstrl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstrl/ChangeLog,v 1.4 2011/06/02 04:08:11 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstrl/ChangeLog,v 1.5 2011/06/02 17:22:06 binki Exp $
+
+*libstrl-0.4 (02 Jun 2011)
+
+ 02 Jun 2011; Nathan Phillip Brink <binki@gentoo.org> +libstrl-0.4.ebuild:
+ Bump to libstrl-0.4, which now installs docs into /usr/share/doc/
+ properly.
02 Jun 2011; Nathan Phillip Brink <binki@gentoo.org> -libstrl-0.2.ebuild:
Drop old libstrl-0.2.
diff --git a/dev-libs/libstrl/libstrl-0.4.ebuild b/dev-libs/libstrl/libstrl-0.4.ebuild
new file mode 100644
index 000000000000..eff672d2cc4a
--- /dev/null
+++ b/dev-libs/libstrl/libstrl-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstrl/libstrl-0.4.ebuild,v 1.1 2011/06/02 17:22:06 binki Exp $
+
+EAPI=3
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), and getline()"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
+SRC_URI="ftp://ohnopub.net/mirror/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x64-macos"
+IUSE="doc static-libs test"
+
+DEPEND="doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )"
+RDEPEND=""
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc doxygen)
+ $(use_with test check)
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ autotools-utils_src_configure
+}