summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2006-08-17 18:28:06 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2006-08-17 18:28:06 +0000
commit55be4a31eb653981be8389aa1f213f3b0cff35c5 (patch)
tree12b89e65d871499e759a5d0cfd10251f8913974b /dev-libs/mapm/mapm-4.9.2.ebuild
parentNote that configuration now uses eselect rather than lapack-config. (diff)
downloadgentoo-2-55be4a31eb653981be8389aa1f213f3b0cff35c5.tar.gz
gentoo-2-55be4a31eb653981be8389aa1f213f3b0cff35c5.tar.bz2
gentoo-2-55be4a31eb653981be8389aa1f213f3b0cff35c5.zip
version bump, new version reported by David Somers (Bug #127534)
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-libs/mapm/mapm-4.9.2.ebuild')
-rw-r--r--dev-libs/mapm/mapm-4.9.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/mapm/mapm-4.9.2.ebuild b/dev-libs/mapm/mapm-4.9.2.ebuild
new file mode 100644
index 000000000000..659ed4f60d86
--- /dev/null
+++ b/dev-libs/mapm/mapm-4.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mapm/mapm-4.9.2.ebuild,v 1.1 2006/08/17 18:28:06 wormo Exp $
+
+DESCRIPTION="Mike's Arbitrary Precision Math Library"
+HOMEPAGE="http://www.tc.umn.edu/~ringx004/mapm-main.html"
+SRC_URI="http://www.tc.umn.edu/~ringx004/${P}.tar.gz"
+
+LICENSE="mapm"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" make_linux_shared_lib
+}
+
+src_compile() {
+ ./make_linux_shared_lib || die
+}
+
+src_install() {
+ dolib.so libmapm.so.0
+ dosym libmapm.so.0 /usr/lib/libmapm.so
+
+ insinto /usr/include
+ doins m_apm.h
+
+ dodoc README article.pdf algorithms.used commentary.txt \
+ cpp_function.ref function.ref history.txt struct.ref
+}