summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2009-09-14 01:35:08 +0000
committerJory Pratt <anarchy@gentoo.org>2009-09-14 01:35:08 +0000
commit61d2ef6cd23baf23c0b1f0a706a02fddae2f82b7 (patch)
treea0fc4b71fd418cacb253e2f5c04ef20652f82af4 /dev-libs/nspr
parentwhitespace (diff)
downloadgentoo-2-61d2ef6cd23baf23c0b1f0a706a02fddae2f82b7.tar.gz
gentoo-2-61d2ef6cd23baf23c0b1f0a706a02fddae2f82b7.tar.bz2
gentoo-2-61d2ef6cd23baf23c0b1f0a706a02fddae2f82b7.zip
use enable ipv6, ensure we enable mozilla and pthread support.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nspr')
-rw-r--r--dev-libs/nspr/nspr-4.8.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-libs/nspr/nspr-4.8.ebuild b/dev-libs/nspr/nspr-4.8.ebuild
index 7006910da9a3..17eb725665c8 100644
--- a/dev-libs/nspr/nspr-4.8.ebuild
+++ b/dev-libs/nspr/nspr-4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.ebuild,v 1.5 2009/08/19 22:22:04 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.ebuild,v 1.6 2009/09/14 01:35:08 anarchy Exp $
inherit eutils multilib toolchain-funcs versionator
@@ -43,14 +43,11 @@ src_compile() {
*) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
esac
- if use ipv6; then
- myconf="${myconf} --enable-ipv6"
- fi
-
myconf="${myconf} --libdir=/usr/$(get_libdir)/nspr \
- --enable-system-sqlite"
+ --enable-system-sqlite --with-mozilla --with-pthreads"
ECONF_SOURCE="../mozilla/nsprpub" econf \
+ $(use_enable ipv6) \
$(use_enable debug) \
${myconf} || die "econf failed"
make CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die