summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-15 14:17:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-15 14:17:03 +0000
commit759cc0b9d8179493545e9fddca268ecbb79d84d9 (patch)
treea6767aec7e613c0d530a59ffb30fc9cc51fbdf5f /dev-libs/pilot-link
parentA struct option patch (hmm do we have a header problem) (diff)
downloadgentoo-2-759cc0b9d8179493545e9fddca268ecbb79d84d9.tar.gz
gentoo-2-759cc0b9d8179493545e9fddca268ecbb79d84d9.tar.bz2
gentoo-2-759cc0b9d8179493545e9fddca268ecbb79d84d9.zip
Headers now go into /usr/include/libpisock to avoid overwriting glibc's
/usr/inclde/getopt.h
Diffstat (limited to 'dev-libs/pilot-link')
-rw-r--r--dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r11
-rw-r--r--dev-libs/pilot-link/files/pilot-link-0.9.0-gentoo.diff49
-rw-r--r--dev-libs/pilot-link/pilot-link-0.9.6-r1.ebuild43
3 files changed, 44 insertions, 49 deletions
diff --git a/dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r1 b/dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r1
new file mode 100644
index 000000000000..6080264f7757
--- /dev/null
+++ b/dev-libs/pilot-link/files/digest-pilot-link-0.9.6-r1
@@ -0,0 +1 @@
+MD5 c8e9861317b2acfb1cb363654b309aa6 pilot-link-0.9.6.tar.gz 4403200
diff --git a/dev-libs/pilot-link/files/pilot-link-0.9.0-gentoo.diff b/dev-libs/pilot-link/files/pilot-link-0.9.0-gentoo.diff
deleted file mode 100644
index 47f81689b1b3..000000000000
--- a/dev-libs/pilot-link/files/pilot-link-0.9.0-gentoo.diff
+++ /dev/null
@@ -1,49 +0,0 @@
---- pilot-link.0.9.0/include/pi-appinfo.hxx~ Fri May 8 02:00:59 1998
-+++ pilot-link.0.9.0/include/pi-appinfo.hxx Thu Jun 7 23:49:40 2001
-@@ -5,7 +5,7 @@
-
- #include "pi-macros.h"
-
--const BASE_APP_INFO_SIZE = 278; // All apps take up 278 bytes of the same stuff
-+const int BASE_APP_INFO_SIZE = 278; // All apps take up 278 bytes of the same stuff
-
- typedef char category_t[16][16];
- typedef const char *const charConst_t;
---- pilot-link.0.9.0/include/pi-dlp.hxx.orig Fri Jun 8 00:11:03 2001
-+++ pilot-link.0.9.0/include/pi-dlp.hxx Fri Jun 8 00:14:24 2001
-@@ -38,7 +38,7 @@
- int findDBInfo(const int cardno, const int start,
- strConst_t dbname, const unsigned long type,
- const unsigned long creator, struct DBInfo *info) const {
-- return dlp_FindDBInfo(_sd, cardno, start, dbname, type, creator,
-+ return dlp_FindDBInfo(_sd, cardno, start,(char *) dbname, type, creator,
- info);
- }
-
-@@ -50,7 +50,7 @@
- int openDB(const int cardno, const int mode, strConst_t name,
- int *db) const {
-
-- return dlp_OpenDB(_sd, cardno, mode, name, db);
-+ return dlp_OpenDB(_sd, cardno, mode,(char *) name, db);
- }
-
- // Close an opened database using the handle returned by openDB
-@@ -81,7 +81,7 @@
- * calling endOfSync, but it's not required
- */
- int addSyncLogEntry(strConst_t entry) const {
-- return dlp_AddSyncLogEntry(_sd, entry);
-+ return dlp_AddSyncLogEntry(_sd,(char *) entry);
- }
-
- /*
-@@ -160,7 +160,7 @@
- int writeRecord(const int handle, const int flags, const recordid_t recID,
- const int catID, const void *data, const int length,
- recordid_t *newID) const {
-- return dlp_WriteRecord(_sd, handle, flags, recID, catID, data,
-+ return dlp_WriteRecord(_sd, handle, flags, recID, catID,(void *) data,
- length, newID);
- }
-
diff --git a/dev-libs/pilot-link/pilot-link-0.9.6-r1.ebuild b/dev-libs/pilot-link/pilot-link-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..0b4eb80b9847
--- /dev/null
+++ b/dev-libs/pilot-link/pilot-link-0.9.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/pilot-link-0.9.6-r1.ebuild,v 1.1 2001/11/15 14:17:03 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A suite of tools contains a series of conduits for moving
+information to and from your Palm device and your desktop or workstation
+system."
+
+SRC_URI="http://www.gnu-designs.com/pilot-link/source/${P}.tar.gz
+ http://www.eskil.org/gnome-pilot/download/tarballs/${P}.tar.gz"
+HOMEPAGE="http://www.gnu-designs.com/pilot-link/"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --includedir=/usr/include/libpisock \
+ --with-tcl=no \
+ --with-itcl=no \
+ --with-tk=no \
+ --with-python=no \
+ --with-java=no \
+ --with-perl5=no
+ assert
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ includedir=${D}/usr/include/pilot-link \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc COPYING COPYING.LIB ChangeLog README TODO
+ docinto sgml
+ dodoc doc/syncabs.sgml
+}