summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-13 23:33:33 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-13 23:33:33 +0000
commit0fbd2ebc4169d08e93a77ea65f1f1b601b89ecae (patch)
treeb86f665419aef602348c0c112faa34eb54e68fd1 /dev-libs/popt
parentarm/ia64/sh stable (diff)
downloadgentoo-2-0fbd2ebc4169d08e93a77ea65f1f1b601b89ecae.tar.gz
gentoo-2-0fbd2ebc4169d08e93a77ea65f1f1b601b89ecae.tar.bz2
gentoo-2-0fbd2ebc4169d08e93a77ea65f1f1b601b89ecae.zip
cleanup
Diffstat (limited to 'dev-libs/popt')
-rw-r--r--dev-libs/popt/files/popt-1.10.4-lib64.patch29
-rw-r--r--dev-libs/popt/files/popt-1.10.4-nls.patch10
-rw-r--r--dev-libs/popt/files/popt-1.10.4-regression.patch4
3 files changed, 13 insertions, 30 deletions
diff --git a/dev-libs/popt/files/popt-1.10.4-lib64.patch b/dev-libs/popt/files/popt-1.10.4-lib64.patch
index 6cf5389f397a..3cc8ce820e8f 100644
--- a/dev-libs/popt/files/popt-1.10.4-lib64.patch
+++ b/dev-libs/popt/files/popt-1.10.4-lib64.patch
@@ -1,29 +1,14 @@
-diff -ru popt-1.10.4.orig/Makefile.am popt-1.10.4/Makefile.am
---- popt-1.10.4.orig/Makefile.am 2005-09-16 14:19:21 +0100
-+++ popt-1.10.4/Makefile.am 2006-10-12 09:36:16 +0100
+It doesnt matter if MARK64 gets set in the configure file as the toplevel
+makefile is the only thing that uses it ... plus we avoid re-running autotools
+
+--- popt-1.10.4/Makefile.in
++++ popt-1.10.4/Makefile.in
@@ -35,7 +35,7 @@
+ TESTS = testit.sh
include_HEADERS = popt.h
-
-usrlibdir = $(libdir)@MARK64@
+usrlibdir = $(libdir)
usrlib_LTLIBRARIES = libpopt.la
-
libpopt_la_SOURCES = popt.c findme.c poptparse.c poptconfig.c popthelp.c
-diff -ru popt-1.10.4.orig/configure.ac popt-1.10.4/configure.ac
---- popt-1.10.4.orig/configure.ac 2005-11-17 20:14:31 +0000
-+++ popt-1.10.4/configure.ac 2006-10-12 09:35:59 +0100
-@@ -59,13 +59,6 @@
- fi
- AC_SUBST(TARGET)
-
--dnl XXX Choose /usr/lib or /usr/lib64 for library installs.
--MARK64=
--case "${target_cpu}" in
--x86_64*|powerpc64*|ppc64*|sparc64*|s390x*) MARK64=64 ;;
--esac
--AC_SUBST(MARK64)
--
- AC_CHECK_HEADERS(alloca.h float.h libintl.h mcheck.h unistd.h)
- AC_MSG_CHECKING(for /usr/ucblib in LIBS)
- if test -d /usr/ucblib ; then
+ libpopt_la_LDFLAGS = -no-undefined @INTLLIBS@ $(am__append_1)
diff --git a/dev-libs/popt/files/popt-1.10.4-nls.patch b/dev-libs/popt/files/popt-1.10.4-nls.patch
index 7550add87b13..0bb2b6cd5393 100644
--- a/dev-libs/popt/files/popt-1.10.4-nls.patch
+++ b/dev-libs/popt/files/popt-1.10.4-nls.patch
@@ -1,6 +1,5 @@
-diff -ur popt-1.10.4.orig/configure.ac popt-1.10.4.my/configure.ac
---- popt-1.10.4.orig/configure.ac 2006-10-21 13:14:32.000000000 +0200
-+++ popt-1.10.4.my/configure.ac 2006-10-21 13:13:24.000000000 +0200
+--- popt-1.10.4.orig/configure.ac
++++ popt-1.10.4.my/configure.ac
@@ -92,14 +92,6 @@
[ : ] )
AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
@@ -29,9 +28,8 @@ diff -ur popt-1.10.4.orig/configure.ac popt-1.10.4.my/configure.ac
-AC_OUTPUT([Doxyfile Makefile intl/Makefile po/Makefile.in])
+AC_OUTPUT([Doxyfile Makefile])
-diff -ur popt-1.10.4.orig/Makefile.am popt-1.10.4.my/Makefile.am
---- popt-1.10.4.orig/Makefile.am 2006-10-21 13:14:32.000000000 +0200
-+++ popt-1.10.4.my/Makefile.am 2006-10-21 13:10:09.000000000 +0200
+--- popt-1.10.4.orig/Makefile.am
++++ popt-1.10.4.my/Makefile.am
@@ -9,8 +9,6 @@
po/*.in po/*.po po/popt.pot \
popt.ps
diff --git a/dev-libs/popt/files/popt-1.10.4-regression.patch b/dev-libs/popt/files/popt-1.10.4-regression.patch
index 141a25e5d573..83ed0229e998 100644
--- a/dev-libs/popt/files/popt-1.10.4-regression.patch
+++ b/dev-libs/popt/files/popt-1.10.4-regression.patch
@@ -1,5 +1,5 @@
---- popt.c.bak 2006-11-04 00:14:31.553881369 +0100
-+++ popt.c 2006-11-04 00:15:19.607576097 +0100
+--- popt.c.bak
++++ popt.c
@@ -748,9 +748,7 @@
if (origOptString == NULL) /* XXX can't happen */
return POPT_ERROR_BADOPT;