summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-10 18:16:18 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-10 18:16:18 +0000
commite54dc9fb50ceaed8faa7ff0d9c01ba3e5093e82e (patch)
treec332b1638b6275be77b90582094011e7e2b83fd6 /dev-libs/protobuf-c
parentAdd arm64/sh love. Add cross-compile support #432106 by Dennis Schridde. (diff)
downloadgentoo-2-e54dc9fb50ceaed8faa7ff0d9c01ba3e5093e82e.tar.gz
gentoo-2-e54dc9fb50ceaed8faa7ff0d9c01ba3e5093e82e.tar.bz2
gentoo-2-e54dc9fb50ceaed8faa7ff0d9c01ba3e5093e82e.zip
Add arm64/mips love. Fix cross-compiling #518440 by Luke-Jr.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-libs/protobuf-c')
-rw-r--r--dev-libs/protobuf-c/ChangeLog6
-rw-r--r--dev-libs/protobuf-c/files/protobuf-c-1.1.0-no-build-tests.patch29
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild15
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-libs/protobuf-c/ChangeLog b/dev-libs/protobuf-c/ChangeLog
index 1d8267cb67f9..523217fd518e 100644
--- a/dev-libs/protobuf-c/ChangeLog
+++ b/dev-libs/protobuf-c/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/protobuf-c
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/ChangeLog,v 1.13 2015/01/10 06:48:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/ChangeLog,v 1.14 2015/03/10 18:16:18 vapier Exp $
+
+ 10 Mar 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/protobuf-c-1.1.0-no-build-tests.patch, protobuf-c-1.1.0.ebuild:
+ Add arm64/mips love. Fix cross-compiling #518440 by Luke-Jr.
*protobuf-c-1.1.0 (10 Jan 2015)
diff --git a/dev-libs/protobuf-c/files/protobuf-c-1.1.0-no-build-tests.patch b/dev-libs/protobuf-c/files/protobuf-c-1.1.0-no-build-tests.patch
new file mode 100644
index 000000000000..4e611d710705
--- /dev/null
+++ b/dev-libs/protobuf-c/files/protobuf-c-1.1.0-no-build-tests.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/518440
+
+avoid compiling tests when we aren't actually testing, especially since it
+requires a compiler to execute which fails when cross-compiling
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -135,7 +135,7 @@ t_generated_code2_test_generated_code2_SOURCES = \
+ t_generated_code2_test_generated_code2_LDADD = \
+ protobuf-c/libprotobuf-c.la
+
+-noinst_PROGRAMS += \
++check_PROGRAMS += \
+ t/generated-code2/cxx-generate-packed-data
+
+ t_generated_code2_cxx_generate_packed_data_SOURCES = \
+@@ -160,12 +160,6 @@ t/test-full.pb.cc t/test-full.pb.h: @PROTOC@ $(top_srcdir)/t/test-full.proto
+ t/generated-code2/test-full-cxx-output.inc: t/generated-code2/cxx-generate-packed-data$(EXEEXT)
+ $(AM_V_GEN)$(top_builddir)/t/generated-code2/cxx-generate-packed-data$(EXEEXT) > $(top_builddir)/t/generated-code2/test-full-cxx-output.inc
+
+-BUILT_SOURCES += \
+- t/test.pb-c.c t/test.pb-c.h \
+- t/test-full.pb-c.c t/test-full.pb-c.h \
+- t/test-full.pb.cc t/test-full.pb.h \
+- t/generated-code2/test-full-cxx-output.inc
+-
+ t_version_version_SOURCES = \
+ t/version/version.c
+ t_version_version_LDADD = \
diff --git a/dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild b/dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild
index 4479ba20a3f9..72ea8aad8fe6 100644
--- a/dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild
+++ b/dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild,v 1.1 2015/01/10 06:48:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/protobuf-c-1.1.0.ebuild,v 1.2 2015/03/10 18:16:18 vapier Exp $
EAPI=5
@@ -15,11 +15,20 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="static-libs"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="static-libs test"
RDEPEND=">=dev-libs/protobuf-2.6.0[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
+ test? ( ${AUTOTOOLS_DEPEND} )
virtual/pkgconfig[${MULTILIB_USEDEP}]"
S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use test ; then
+ epatch "${FILESDIR}"/${PN}-1.1.0-no-build-tests.patch
+ AUTOTOOLS_AUTORECONF=true
+ fi
+ autotools-multilib_src_prepare
+}