summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-12-13 18:30:22 +0000
committerDane Smith <c1pher@gentoo.org>2010-12-13 18:30:22 +0000
commit0d0aad90e934215f982899162c967dd2e14d6158 (patch)
tree94cd6456d99330bf274a02fc457667f3be4d53ad /dev-libs/pth/pth-2.0.7-r2.ebuild
parentold (diff)
downloadgentoo-2-0d0aad90e934215f982899162c967dd2e14d6158.tar.gz
gentoo-2-0d0aad90e934215f982899162c967dd2e14d6158.tar.bz2
gentoo-2-0d0aad90e934215f982899162c967dd2e14d6158.zip
Revbump for dev-libs/pth. Fixed parallel make install issue. Addressed small repoman warnings.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'dev-libs/pth/pth-2.0.7-r2.ebuild')
-rw-r--r--dev-libs/pth/pth-2.0.7-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/pth/pth-2.0.7-r2.ebuild b/dev-libs/pth/pth-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..99d0a9be4d7a
--- /dev/null
+++ b/dev-libs/pth/pth-2.0.7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.7-r2.ebuild,v 1.1 2010/12/13 18:30:22 c1pher Exp $
+
+inherit eutils fixheadtails libtool
+
+DESCRIPTION="GNU Portable Threads"
+HOMEPAGE="http://www.gnu.org/software/pth/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.0.5-parallelfix.patch
+ epatch "${FILESDIR}"/${PN}-2.0.6-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-2.0.6-sigstack.patch
+ epatch "${FILESDIR}"/${PN}-2.0.7-parallel-install.patch
+
+ ht_fix_file aclocal.m4 configure
+
+ elibtoolize
+}
+
+src_compile() {
+ local conf
+ use debug && conf="${conf} --enable-debug" # have a bug --disable-debug and shared
+ econf ${conf} || die
+ emake || die
+}
+
+src_install() {
+ #Parallel install issuse fixed with parallel-install.patch.
+ #Submitted upstream on 12-13-2010.
+ emake DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS ChangeLog NEWS README THANKS USERS || die
+}