summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-10-30 02:43:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-10-30 02:43:21 +0000
commitb0a7e6c4d77e4935c8b4225fab9077141929235f (patch)
tree02ee0813140a6afb61576f9283e4e016a5382738 /dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild
parentnew modules for tc2 (diff)
downloadgentoo-2-b0a7e6c4d77e4935c8b4225fab9077141929235f.tar.gz
gentoo-2-b0a7e6c4d77e4935c8b4225fab9077141929235f.tar.bz2
gentoo-2-b0a7e6c4d77e4935c8b4225fab9077141929235f.zip
new modules for tc2
Diffstat (limited to 'dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild')
-rw-r--r--dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild b/dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild
new file mode 100644
index 000000000000..99c3977a0b88
--- /dev/null
+++ b/dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tc2-modules/tc2-modules-0.5.0.ebuild,v 1.1 2003/10/30 02:43:20 seemant Exp $
+
+IUSE="static"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Modules for tc2."
+HOMEPAGE="http://tc2.sourceforge.net"
+SRC_URI="mirror://sourceforge/tc2/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="OpenSoftware"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
+
+DEPEND=">=dev-libs/tc2-0.5.0"
+
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+ use static && myconf="${myconf} --enable-static"
+
+ econf ${myconf} || die "configure failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}