summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-01-23 17:14:04 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-01-23 17:14:04 +0000
commita8aceac6ccd7a8efe66d66919f1525612722dd3b (patch)
tree672511e49da44c6249940f46a086c81cede17bf6 /dev-libs/tntnet
parentAdd ~alpha/~sparc, x86 stable (diff)
downloadgentoo-2-a8aceac6ccd7a8efe66d66919f1525612722dd3b.tar.gz
gentoo-2-a8aceac6ccd7a8efe66d66919f1525612722dd3b.tar.bz2
gentoo-2-a8aceac6ccd7a8efe66d66919f1525612722dd3b.zip
Version bumped, thanks to jo01 for the info. Now also install the examples, finally solving Bug #180319.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-libs/tntnet')
-rw-r--r--dev-libs/tntnet/ChangeLog10
-rw-r--r--dev-libs/tntnet/files/digest-tntnet-1.6.13
-rw-r--r--dev-libs/tntnet/tntnet-1.6.1.ebuild60
3 files changed, 71 insertions, 2 deletions
diff --git a/dev-libs/tntnet/ChangeLog b/dev-libs/tntnet/ChangeLog
index 46bd2587a75b..ddedd8e75b30 100644
--- a/dev-libs/tntnet/ChangeLog
+++ b/dev-libs/tntnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/tntnet
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tntnet/ChangeLog,v 1.4 2007/05/31 10:16:42 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tntnet/ChangeLog,v 1.5 2008/01/23 17:14:03 zzam Exp $
+
+*tntnet-1.6.1 (23 Jan 2008)
+
+ 23 Jan 2008; Matthias Schwarzott <zzam@gentoo.org> +tntnet-1.6.1.ebuild:
+ Version bumped, thanks to jo01 for the info. Now also install the examples,
+ finally solving Bug #180319.
31 May 2007; Matthias Schwarzott <zzam@gentoo.org> tntnet-1.6.0-r1.ebuild:
Switch over to already existing use-flag examples (instead of demo).
diff --git a/dev-libs/tntnet/files/digest-tntnet-1.6.1 b/dev-libs/tntnet/files/digest-tntnet-1.6.1
new file mode 100644
index 000000000000..5cb69b83143a
--- /dev/null
+++ b/dev-libs/tntnet/files/digest-tntnet-1.6.1
@@ -0,0 +1,3 @@
+MD5 73455472b31b83eadc0407905e2885e3 tntnet-1.6.1.tar.gz 1948115
+RMD160 6e9e8021b4d7f905cbfa05a4ad65ff250977da5e tntnet-1.6.1.tar.gz 1948115
+SHA256 389bd267458ca8b45ce6e3a081160f2aeb4ffb6d7e0bb57749407f706a82d951 tntnet-1.6.1.tar.gz 1948115
diff --git a/dev-libs/tntnet/tntnet-1.6.1.ebuild b/dev-libs/tntnet/tntnet-1.6.1.ebuild
new file mode 100644
index 000000000000..a527f656518d
--- /dev/null
+++ b/dev-libs/tntnet/tntnet-1.6.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tntnet/tntnet-1.6.1.ebuild,v 1.1 2008/01/23 17:14:03 zzam Exp $
+
+DESCRIPTION="A modular, multithreaded webapplicationserver extensible with C++."
+HOMEPAGE="http://www.tntnet.org/index.hms"
+SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl gnutls examples"
+
+RDEPEND="dev-libs/cxxtools
+ sys-libs/zlib
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( dev-libs/openssl )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/zip"
+
+src_compile() {
+ local myconf=""
+ if use ssl; then
+ if use gnutls; then
+ einfo "Using gnutls for ssl support."
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ einfo "Using openssl for ssl support."
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ einfo "Disabled ssl"
+ myconf="${myconf} --with-ssl=no"
+ fi
+ if use examples; then
+ myconf="${myconf} --with-demos=yes"
+ else
+ myconf="${myconf} --with-demos=no"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO doc/*.pdf
+
+ if use examples; then
+ cd "${S}/sdk/demos"
+ make clean
+ rm -rf .deps */.deps .libs */.libs
+
+ local dir="/usr/share/doc/${PF}/examples"
+ dodir "${dir}"
+ cp -r "${S}"/sdk/demos/* "${D}${dir}"
+ fi
+}