summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-07-17 08:28:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-07-17 08:28:02 +0000
commit2af5f6d585328712a916d0e1e2be704cf5742647 (patch)
tree58ca853c7d892972599739d4268233b8d14f4974 /dev-libs/xqilla
parentfix broken comment (diff)
downloadgentoo-2-2af5f6d585328712a916d0e1e2be704cf5742647.tar.gz
gentoo-2-2af5f6d585328712a916d0e1e2be704cf5742647.tar.bz2
gentoo-2-2af5f6d585328712a916d0e1e2be704cf5742647.zip
Fix building with GCC 4.7 (bug #441800).
Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'dev-libs/xqilla')
-rw-r--r--dev-libs/xqilla/ChangeLog8
-rw-r--r--dev-libs/xqilla/files/xqilla-2.2.4-gcc47.patch15
-rw-r--r--dev-libs/xqilla/xqilla-2.2.4.ebuild5
3 files changed, 24 insertions, 4 deletions
diff --git a/dev-libs/xqilla/ChangeLog b/dev-libs/xqilla/ChangeLog
index cbbc1e906c3d..118632c5f75d 100644
--- a/dev-libs/xqilla/ChangeLog
+++ b/dev-libs/xqilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/xqilla
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.13 2012/05/24 20:25:19 dev-zero Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.14 2013/07/17 08:28:02 dirtyepic Exp $
+
+ 17 Jul 2013; Ryan Hill <dirtyepic@gentoo.org> xqilla-2.2.4.ebuild,
+ +files/xqilla-2.2.4-gcc47.patch:
+ Fix building with GCC 4.7 (bug #441800).
*xqilla-2.3.0 (24 May 2012)
diff --git a/dev-libs/xqilla/files/xqilla-2.2.4-gcc47.patch b/dev-libs/xqilla/files/xqilla-2.2.4-gcc47.patch
new file mode 100644
index 000000000000..d7f5cde5993e
--- /dev/null
+++ b/dev-libs/xqilla/files/xqilla-2.2.4-gcc47.patch
@@ -0,0 +1,15 @@
+Fix build failure with GCC 4.7.
+https://bugs.gentoo.org/441800
+
+
+--- a/src/items/DatatypeFactoryTemplate.hpp
++++ b/src/items/DatatypeFactoryTemplate.hpp
+@@ -79,7 +79,7 @@ public:
+ AnyAtomicType::Ptr createInstance(const XMLCh* value,
+ const DynamicContext* context) const
+ {
+- return createInstanceNoCheck(DatatypeFactoryTemplate<TYPE>::getPrimitiveTypeURI(),
++ return this->createInstanceNoCheck(DatatypeFactoryTemplate<TYPE>::getPrimitiveTypeURI(),
+ DatatypeFactoryTemplate<TYPE>::getPrimitiveTypeName(), value, context);
+ }
+
diff --git a/dev-libs/xqilla/xqilla-2.2.4.ebuild b/dev-libs/xqilla/xqilla-2.2.4.ebuild
index 54d6ad587c44..b74576e5f18a 100644
--- a/dev-libs/xqilla/xqilla-2.2.4.ebuild
+++ b/dev-libs/xqilla/xqilla-2.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.4.ebuild,v 1.2 2011/09/24 12:36:27 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.4.ebuild,v 1.3 2013/07/17 08:28:02 dirtyepic Exp $
EAPI="2"
inherit autotools base
@@ -29,6 +29,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PV}-respect-ldflags-no-rpath.patch"
"${FILESDIR}/${P}-gcc46.patch"
+ "${FILESDIR}/${P}-gcc47.patch"
)
S="${WORKDIR}/${MY_P}"