summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-07-15 14:44:36 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-07-15 14:44:36 +0000
commit11632f9450c8debb009bd372980c4d893999ced2 (patch)
tree8c95dd9ecde9223a5a28ba7880b270ccacfac3f7 /dev-libs
parentold (diff)
downloadgentoo-2-11632f9450c8debb009bd372980c4d893999ced2.tar.gz
gentoo-2-11632f9450c8debb009bd372980c4d893999ced2.tar.bz2
gentoo-2-11632f9450c8debb009bd372980c4d893999ced2.zip
Fixed bug #181972, added fix for gcc-4.2
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog10
-rw-r--r--dev-libs/boost/boost-1.34.0-r1.ebuild (renamed from dev-libs/boost/boost-1.34.0.ebuild)13
-rw-r--r--dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch15
-rw-r--r--dev-libs/boost/files/digest-boost-1.34.0-r1 (renamed from dev-libs/boost/files/digest-boost-1.34.0)0
4 files changed, 36 insertions, 2 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 9b33a8957322..b26d226c6eb2 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.118 2007/07/15 10:55:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.119 2007/07/15 14:44:36 dev-zero Exp $
+
+*boost-1.34.0-r1 (15 Jul 2007)
+
+ 15 Jul 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/boost-1.34.0-gcc42-atomicity.h.patch, -boost-1.34.0.ebuild,
+ +boost-1.34.0-r1.ebuild:
+ Added creation of symlinks when built with debug (bug #181972)
+ Added patch for gcc-4.2
15 Jul 2007; Tiziano Müller <dev-zero@gentoo.org> boost-1.34.0.ebuild:
Corrected dohtml usage (thanks to kolmodin)
diff --git a/dev-libs/boost/boost-1.34.0.ebuild b/dev-libs/boost/boost-1.34.0-r1.ebuild
index bb94ac4fc24a..5aee08e6da74 100644
--- a/dev-libs/boost/boost-1.34.0.ebuild
+++ b/dev-libs/boost/boost-1.34.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.0.ebuild,v 1.9 2007/07/15 10:55:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.0-r1.ebuild,v 1.1 2007/07/15 14:44:36 dev-zero Exp $
inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -49,6 +49,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc42-atomicity.h.patch"
+
rm boost-build.jam
# This enables building the boost.random library with /dev/urandom support
@@ -189,10 +191,19 @@ src_install () {
cd "${D}/usr/$(get_libdir)"
+ # If built with debug enabled, all libraries get a 'd' postfix,
+ # this breaks linking other apps against boost (bug #181972)
+ if use debug ; then
+ for lib in $(ls -1 libboost_*) ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-d\././' -e 's/d\././' <<< ${lib})"
+ done
+ fi
+
for lib in $(ls -1 libboost_thread-mt.*) ; do
dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
done
+
if use pyste; then
cd "${S}/libs/python/pyste/install"
distutils_src_install
diff --git a/dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch b/dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch
new file mode 100644
index 000000000000..c2ca7f20512b
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.34.0-gcc42-atomicity.h.patch
@@ -0,0 +1,15 @@
+--- boost_1_34_0/boost/detail/atomic_count_gcc.hpp 2005/04/02 11:37:53 1.5
++++ boost_1_34_0/boost/detail/atomic_count_gcc.hpp 2007/05/21 01:34:43 1.5.8.1
+@@ -17,7 +17,11 @@
+ // http://www.boost.org/LICENSE_1_0.txt)
+ //
+
+-#include <bits/atomicity.h>
++#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 2))
++# include <ext/atomicity.h>
++#else
++# include <bits/atomicity.h>
++#endif
+
+ namespace boost
+ {
diff --git a/dev-libs/boost/files/digest-boost-1.34.0 b/dev-libs/boost/files/digest-boost-1.34.0-r1
index 792d3db7556c..792d3db7556c 100644
--- a/dev-libs/boost/files/digest-boost-1.34.0
+++ b/dev-libs/boost/files/digest-boost-1.34.0-r1