summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-11 23:50:05 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-11 23:50:05 +0000
commit1c36c37b0d570cb33b77b78b8f5ed48242b1213c (patch)
tree85036265e0c5622db1897619fc87c9deff3afb3d /dev-libs
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-1c36c37b0d570cb33b77b78b8f5ed48242b1213c.tar.gz
gentoo-2-1c36c37b0d570cb33b77b78b8f5ed48242b1213c.tar.bz2
gentoo-2-1c36c37b0d570cb33b77b78b8f5ed48242b1213c.zip
-fPIC fix
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libebml/ChangeLog7
-rw-r--r--dev-libs/libebml/libebml-0.6.4.ebuild10
-rw-r--r--dev-libs/libebml/libebml-0.6.5.ebuild10
3 files changed, 24 insertions, 3 deletions
diff --git a/dev-libs/libebml/ChangeLog b/dev-libs/libebml/ChangeLog
index 4163dcb4ebec..4b08e1040241 100644
--- a/dev-libs/libebml/ChangeLog
+++ b/dev-libs/libebml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libebml
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.9 2004/03/17 22:09:11 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.10 2004/04/11 23:50:05 lv Exp $
+
+ 11 Apr 2004; Travis Tilley <lv@gentoo.org> libebml-0.6.4.ebuild,
+ libebml-0.6.5.ebuild:
+ added an -fPIC fix for compiling vlc on amd64. see bug #47500 for more
+ information.
*libebml-0.6.5 (18 Mar 2004)
diff --git a/dev-libs/libebml/libebml-0.6.4.ebuild b/dev-libs/libebml/libebml-0.6.4.ebuild
index aeb53c6f01e0..ec77c0bb7c03 100644
--- a/dev-libs/libebml/libebml-0.6.4.ebuild
+++ b/dev-libs/libebml/libebml-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-0.6.4.ebuild,v 1.4 2004/03/16 04:42:20 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-0.6.4.ebuild,v 1.5 2004/04/11 23:50:05 lv Exp $
IUSE=""
@@ -18,6 +18,14 @@ DEPEND="virtual/glibc"
src_compile() {
cd ${S}/make/linux
+
+ # This fix is necessary due to libebml being used to generate
+ # shared libraries, such as the vlc plugin for mozilla. on archs
+ # that require shared objects to be compiled with -fPIC, this
+ # really shouldn't happen, but libebml doesn't produce an so.
+ # Travis Tilley <lv@gentoo.org>
+ append-flags -fPIC
+
sed -i -e 's/CXXFLAGS=/CXXFLAGS+=/g' Makefile
make PREFIX=/usr || die "make failed"
}
diff --git a/dev-libs/libebml/libebml-0.6.5.ebuild b/dev-libs/libebml/libebml-0.6.5.ebuild
index 602c7c2102e5..6c6a408e568b 100644
--- a/dev-libs/libebml/libebml-0.6.5.ebuild
+++ b/dev-libs/libebml/libebml-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-0.6.5.ebuild,v 1.1 2004/03/17 22:09:11 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-0.6.5.ebuild,v 1.2 2004/04/11 23:50:05 lv Exp $
IUSE=""
@@ -18,6 +18,14 @@ DEPEND="virtual/glibc"
src_compile() {
cd ${S}/make/linux
+
+ # This fix is necessary due to libebml being used to generate
+ # shared libraries, such as the vlc plugin for mozilla. on archs
+ # that require shared objects to be compiled with -fPIC, this
+ # really shouldn't happen, but libebml doesn't produce an so.
+ # Travis Tilley <lv@gentoo.org>
+ append-flags -fPIC
+
sed -i -e 's/CXXFLAGS=/CXXFLAGS+=/g' Makefile
make PREFIX=/usr || die "make failed"
}