summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-08-25 16:39:35 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-08-25 16:39:35 +0000
commit268cca489cd1ca7f0ad07bc618d5b9237287b3c4 (patch)
tree8657bfa9e43701be9eb52d19193a7af92b37c95a /dev-libs
parentVersion bump, bug #481212. (diff)
downloadgentoo-2-268cca489cd1ca7f0ad07bc618d5b9237287b3c4.tar.gz
gentoo-2-268cca489cd1ca7f0ad07bc618d5b9237287b3c4.tar.bz2
gentoo-2-268cca489cd1ca7f0ad07bc618d5b9237287b3c4.zip
Version bump, bug #480868.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland/ChangeLog8
-rw-r--r--dev-libs/wayland/wayland-1.2.1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index 6939bb55b238..68dbddd0b643 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/wayland
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.21 2013/07/17 16:40:23 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.22 2013/08/25 16:39:35 chithanh Exp $
+
+*wayland-1.2.1 (25 Aug 2013)
+
+ 25 Aug 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +wayland-1.2.1.ebuild:
+ Version bump, bug #480868.
17 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
wayland-1.2.0.ebuild:
diff --git a/dev-libs/wayland/wayland-1.2.1.ebuild b/dev-libs/wayland/wayland-1.2.1.ebuild
new file mode 100644
index 000000000000..4e0e5cba9cfb
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.2.1.ebuild,v 1.1 2013/08/25 16:39:35 chithanh Exp $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/expat
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ myconf="$(use_enable static-libs static) \
+ $(use_enable doc documentation)"
+ if tc-is-cross-compiler ; then
+ myconf+=" --disable-scanner"
+ fi
+ econf ${myconf}
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}