summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-07-05 19:45:51 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-07-05 19:45:51 +0000
commit370155e0ea77fd34fcab3e18687deb3deb1e6a53 (patch)
treee2d4ccf182ebf4693880004338bd5b5877d6b698 /dev-libs
parentright... typos (diff)
downloadgentoo-2-370155e0ea77fd34fcab3e18687deb3deb1e6a53.tar.gz
gentoo-2-370155e0ea77fd34fcab3e18687deb3deb1e6a53.tar.bz2
gentoo-2-370155e0ea77fd34fcab3e18687deb3deb1e6a53.zip
Initial release for commonc++
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/commonc++/ChangeLog10
-rw-r--r--dev-libs/commonc++/commonc++-1.9.7.ebuild33
-rw-r--r--dev-libs/commonc++/files/digest-commonc++-1.9.71
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/commonc++/ChangeLog b/dev-libs/commonc++/ChangeLog
new file mode 100644
index 000000000000..1986e2b26965
--- /dev/null
+++ b/dev-libs/commonc++/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/commonc++/ChangeLog,v 1.1 2002/07/05 19:45:51 naz Exp $
+
+*commonc++-1.9.7 (05 Jul 2002)
+
+ 05 Jul 2002; Michael Nazaroff <naz@gentoo.org> commonc++-1.9.7:
+ This changelog is for the initial release of commonc++-1.9.7.ebuild which is
+ just a library needed for a few gnu applications.
+
diff --git a/dev-libs/commonc++/commonc++-1.9.7.ebuild b/dev-libs/commonc++/commonc++-1.9.7.ebuild
new file mode 100644
index 000000000000..f9a8a0281884
--- /dev/null
+++ b/dev-libs/commonc++/commonc++-1.9.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Michael Nazaroff (Naz) <naz@themoonsofjupiter.net>
+#
+
+S=${WORKDIR}/CommonC++-1.9.7
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
+threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
+and system services"
+SRC_URI="http://ftp.azc.uam.mx/mirrors/gnu/commonc++/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commonc++/"
+
+
+DEPEND="virtual/glibc
+ sys-libs/zlib
+ dev-libs/libxml2"
+
+src_compile() {
+
+ cd ${S}
+ ./configure \
+ --prefix=/usr --host=${CHOST} --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die "./configure failed"
+ emake || die "make failed"
+
+}
+
+src_install () {
+
+ make prefix=${D} install || die
+ dodoc AUTHORS INSTALL NEWS OVERVIEW.TXT ChangeLog\
+ README THANKS TODO
+}
diff --git a/dev-libs/commonc++/files/digest-commonc++-1.9.7 b/dev-libs/commonc++/files/digest-commonc++-1.9.7
new file mode 100644
index 000000000000..a29592b05c0d
--- /dev/null
+++ b/dev-libs/commonc++/files/digest-commonc++-1.9.7
@@ -0,0 +1 @@
+MD5 d1e9f2d5db4a3c667c08d36a0d261d74 commonc++-1.9.7.tar.gz 741527