summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-14 23:01:13 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-14 23:01:13 +0000
commit5a27ac445393755be667b3cac434e03a6476ce4f (patch)
tree183fda0a7611ff39559ac6d1d9d95b6ff01cbc7d /dev-libs
parentEnable multilib support, bug #505006. (diff)
downloadgentoo-2-5a27ac445393755be667b3cac434e03a6476ce4f.tar.gz
gentoo-2-5a27ac445393755be667b3cac434e03a6476ce4f.tar.bz2
gentoo-2-5a27ac445393755be667b3cac434e03a6476ce4f.zip
Enable multilib support, bug #505008.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libverto/ChangeLog9
-rw-r--r--dev-libs/libverto/libverto-0.2.5-r1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-libs/libverto/ChangeLog b/dev-libs/libverto/ChangeLog
index fea9a751ef1c..8805994aa2a8 100644
--- a/dev-libs/libverto/ChangeLog
+++ b/dev-libs/libverto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libverto
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/ChangeLog,v 1.22 2013/08/16 17:04:28 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/ChangeLog,v 1.23 2014/05/14 23:01:13 mgorny Exp $
+
+*libverto-0.2.5-r1 (14 May 2014)
+
+ 14 May 2014; Michał Górny <mgorny@gentoo.org> +libverto-0.2.5-r1.ebuild:
+ Enable multilib support, bug #505008.
16 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> libverto-0.2.5.ebuild:
Add ~mips keyword, wrt bug #412489
diff --git a/dev-libs/libverto/libverto-0.2.5-r1.ebuild b/dev-libs/libverto/libverto-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..0fd090673910
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.5-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/libverto-0.2.5-r1.ebuild,v 1.1 2014/05/14 23:01:12 mgorny Exp $
+
+EAPI=5
+
+inherit multilib-minimal
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.29[${MULTILIB_USEDEP}] )
+ libev? ( >=dev-libs/libev-4.11[${MULTILIB_USEDEP}] )
+ libevent? ( >=dev-libs/libevent-2.0[${MULTILIB_USEDEP}] )
+ tevent? ( sys-libs/tevent[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+ use static-libs || prune_libtool_files --all
+}