summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-25 05:14:36 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-25 05:14:36 +0000
commit875a42d77bafaf3dc02051613b17c2d03c03af7c (patch)
tree52e08c64269ebd4b1d989775321e034599472cc8 /dev-libs
parentMask dev-libs/libnl-2* (bug #342461). (diff)
downloadgentoo-2-875a42d77bafaf3dc02051613b17c2d03c03af7c.tar.gz
gentoo-2-875a42d77bafaf3dc02051613b17c2d03c03af7c.tar.bz2
gentoo-2-875a42d77bafaf3dc02051613b17c2d03c03af7c.zip
Version bump by Kfir Lavi (bug #342461).
(Portage version: 2.2.0_alpha1/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/ChangeLog7
-rw-r--r--dev-libs/libnl/libnl-2.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index 5221c2962d04..d5a67b646370 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.41 2010/08/11 00:53:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.42 2010/10/25 05:14:36 jer Exp $
+
+*libnl-2.0 (25 Oct 2010)
+
+ 25 Oct 2010; Jeroen Roovers <jer@gentoo.org> +libnl-2.0.ebuild:
+ Version bump by Kfir Lavi (bug #342461).
11 Aug 2010; Jeroen Roovers <jer@gentoo.org> libnl-1.1-r2.ebuild:
Optionally install API documentation by Thomas Klute (bug #328625).
diff --git a/dev-libs/libnl/libnl-2.0.ebuild b/dev-libs/libnl/libnl-2.0.ebuild
new file mode 100644
index 000000000000..87aae60a6c8d
--- /dev/null
+++ b/dev-libs/libnl/libnl-2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-2.0.ebuild,v 1.1 2010/10/25 05:14:36 jer Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+DESCRIPTION="A library for applications dealing with netlink socket"
+HOMEPAGE="http://people.suug.ch/~tgr/libnl/"
+SRC_URI="http://people.suug.ch/~tgr/libnl/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ cd "${S}/doc"
+ emake gendoc || die "emake gendoc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+
+ if use doc ; then
+ cd "${S}/doc"
+ dohtml -r html/*
+ fi
+}