summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-11-25 20:58:35 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-11-25 20:58:35 +0000
commitb4cdc33ce5e1f13955ab30065a39168998ddcd28 (patch)
treea73e87147a560fb384c0a3a6d1d312073f8c7530 /dev-libs
parentMoving www-plugins/mozilla-weave to www-plugins/weave. (diff)
downloadgentoo-2-b4cdc33ce5e1f13955ab30065a39168998ddcd28.tar.gz
gentoo-2-b4cdc33ce5e1f13955ab30065a39168998ddcd28.tar.bz2
gentoo-2-b4cdc33ce5e1f13955ab30065a39168998ddcd28.zip
Version bumps
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librep/ChangeLog9
-rw-r--r--dev-libs/librep/librep-0.90.3.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index d4fc4711a453..abb6cb87f8d1 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/librep
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.53 2009/03/08 20:06:34 truedfx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.54 2009/11/25 20:58:35 truedfx Exp $
+
+*librep-0.90.3 (25 Nov 2009)
+
+ 25 Nov 2009; Harald van Dijk <truedfx@gentoo.org> +librep-0.90.3.ebuild:
+ Version bump
*librep-0.17.3 (05 Mar 2009)
diff --git a/dev-libs/librep/librep-0.90.3.ebuild b/dev-libs/librep/librep-0.90.3.ebuild
new file mode 100644
index 000000000000..f6ac86a7d4c6
--- /dev/null
+++ b/dev-libs/librep/librep-0.90.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.90.3.ebuild,v 1.1 2009/11/25 20:58:35 truedfx Exp $
+
+inherit eutils multilib elisp-common
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="http://librep.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs readline"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.17.3-disable-elisp.patch
+}
+
+src_compile() {
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-gmp \
+ --without-ffi \
+ $(use_with readline) || die "configure failed"
+
+ emake || die "make failed"
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO TREE
+ docinto doc
+ dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}