summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-02-11 03:30:01 +0000
committerJory Pratt <anarchy@gentoo.org>2010-02-11 03:30:01 +0000
commitd923e9aeeffec4569b932a330be6bcd3cb20cb95 (patch)
tree3bd307362b08dff2d5628961b62dc4dbfcd2f236 /dev-libs
parentupdate for upstream concerns, thanks to Wan-Teh for his concerns. (diff)
downloadgentoo-2-d923e9aeeffec4569b932a330be6bcd3cb20cb95.tar.gz
gentoo-2-d923e9aeeffec4569b932a330be6bcd3cb20cb95.tar.bz2
gentoo-2-d923e9aeeffec4569b932a330be6bcd3cb20cb95.zip
update for upstream concerns, thanks to Wan-Teh for his concerns.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nspr/ChangeLog8
-rw-r--r--dev-libs/nspr/nspr-4.8.3-r2.ebuild (renamed from dev-libs/nspr/nspr-4.8.3-r1.ebuild)14
-rw-r--r--dev-libs/nspr/nspr-4.8.3.ebuild88
3 files changed, 15 insertions, 95 deletions
diff --git a/dev-libs/nspr/ChangeLog b/dev-libs/nspr/ChangeLog
index d18d63e87695..1f4d0faa143a 100644
--- a/dev-libs/nspr/ChangeLog
+++ b/dev-libs/nspr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nspr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.134 2010/02/09 04:33:08 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.135 2010/02/11 03:30:01 anarchy Exp $
+
+*nspr-4.8.3-r2 (11 Feb 2010)
+
+ 11 Feb 2010; <anarchy@gentoo.org> -nspr-4.8.3.ebuild,
+ -nspr-4.8.3-r1.ebuild, +nspr-4.8.3-r2.ebuild:
+ Finish fixing upstream conerns about build issues, move to /usr/lib{64}
*nspr-4.8.3-r1 (09 Feb 2010)
diff --git a/dev-libs/nspr/nspr-4.8.3-r1.ebuild b/dev-libs/nspr/nspr-4.8.3-r2.ebuild
index b6e57ec2c37b..54c07a27ff1a 100644
--- a/dev-libs/nspr/nspr-4.8.3-r1.ebuild
+++ b/dev-libs/nspr/nspr-4.8.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.3-r1.ebuild,v 1.1 2010/02/09 04:33:08 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.3-r2.ebuild,v 1.1 2010/02/11 03:30:01 anarchy Exp $
inherit eutils multilib toolchain-funcs versionator
@@ -41,7 +41,7 @@ src_compile() {
*) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
esac
- myconf="${myconf} --libdir=/usr/$(get_libdir)/nspr"
+ myconf="${myconf} --libdir=/usr/$(get_libdir)"
ECONF_SOURCE="../mozilla/nsprpub" econf \
$(use_enable debug) \
@@ -56,14 +56,16 @@ src_install () {
cd "${S}"/build
emake DESTDIR="${D}" install || die "emake install failed"
- cd "${D}"/usr/$(get_libdir)/nspr
+ cd "${D}"/usr/$(get_libdir)
+ for file in *.a; do
+ einfo "removing static libraries as upstream has requested!"
+ rm ${file}
+ done
+
for file in *.so; do
mv ${file} ${file}.${MINOR_VERSION}
ln -s ${file}.${MINOR_VERSION} ${file}
done
- # cope with libraries being in /usr/lib/nspr
- dodir /etc/env.d
- echo "LDPATH=/usr/$(get_libdir)/nspr" > "${D}/etc/env.d/08nspr"
# install nspr-config
dobin "${S}"/build/config/nspr-config
diff --git a/dev-libs/nspr/nspr-4.8.3.ebuild b/dev-libs/nspr/nspr-4.8.3.ebuild
deleted file mode 100644
index faceec95bf10..000000000000
--- a/dev-libs/nspr/nspr-4.8.3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.3.ebuild,v 1.1 2010/02/07 19:13:59 anarchy Exp $
-
-inherit eutils multilib toolchain-funcs versionator
-
-MIN_PV="$(get_version_component_range 2)"
-
-DESCRIPTION="Netscape Portable Runtime"
-HOMEPAGE="http://www.mozilla.org/projects/nspr/"
-SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
-
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="ipv6 debug"
-
-DEPEND=">=dev-db/sqlite-3.5"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- mkdir build inst
- epatch "${FILESDIR}"/${PN}-4.8-config.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
- epatch "${FILESDIR}"/${PN}-4.7.0-prtime.patch
- epatch "${FILESDIR}"/${PN}-4.8-pkgconfig-gentoo-1.patch
-
- # Respect LDFLAGS
- sed -i -e 's/\$(MKSHLIB) \$(OBJS)/\$(MKSHLIB) \$(LDFLAGS) \$(OBJS)/g' \
- mozilla/nsprpub/config/rules.mk
-}
-
-src_compile() {
- cd "${S}"/build
-
- echo > "${T}"/test.c
- $(tc-getCC) -c "${T}"/test.c -o "${T}"/test.o
- case $(file "${T}"/test.o) in
- *64-bit*) myconf="${myconf} --enable-64bit";;
- *32-bit*) ;;
- *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
- esac
-
- myconf="${myconf} --libdir=/usr/$(get_libdir)/nspr \
- --enable-system-sqlite --with-mozilla --with-pthreads"
-
- ECONF_SOURCE="../mozilla/nsprpub" econf \
- $(use_enable ipv6) \
- $(use_enable debug) \
- ${myconf} || die "econf failed"
- make CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
-}
-
-src_install () {
- # Their build system is royally confusing, as usual
- MINOR_VERSION=${MIN_PV} # Used for .so version
- cd "${S}"/build
- emake DESTDIR="${D}" install || die "emake install failed"
-
- cd "${D}"/usr/$(get_libdir)/nspr
- for file in *.so; do
- mv ${file} ${file}.${MINOR_VERSION}
- ln -s ${file}.${MINOR_VERSION} ${file}
- done
- # cope with libraries being in /usr/lib/nspr
- dodir /etc/env.d
- echo "LDPATH=/usr/$(get_libdir)/nspr" > "${D}/etc/env.d/08nspr"
-
- # install nspr-config
- dobin "${S}"/build/config/nspr-config
-
- # create pkg-config file
- insinto /usr/$(get_libdir)/pkgconfig/
- doins "${S}"/build/config/nspr.pc
-
- # Remove stupid files in /usr/bin
- rm "${D}"/usr/bin/prerr.properties
-}
-
-pkg_postinst() {
- ewarn
- ewarn "Please make sure you run revdep-rebuild after upgrade."
- ewarn "This is *extremely* important to ensure your system nspr works properly."
- ewarn
-}