summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-26 11:37:50 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-26 11:37:50 +0000
commitf69b3ecac1a39f56ab29a74f56f195ff73549090 (patch)
treedecf6826e2f23ab7a5abc60b496221c4d84b8ad7 /dev-libs
parentDrop obsolete line (diff)
downloadgentoo-2-f69b3ecac1a39f56ab29a74f56f195ff73549090.tar.gz
gentoo-2-f69b3ecac1a39f56ab29a74f56f195ff73549090.tar.bz2
gentoo-2-f69b3ecac1a39f56ab29a74f56f195ff73549090.zip
Fix building against sys-libs/ncurses[tinfo] (bug #526902). EAPI bump. Remove pointless USE=debug.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libchewing/ChangeLog13
-rw-r--r--dev-libs/libchewing/files/0.3.2-fix-chewing-zuin-String.patch25
-rw-r--r--dev-libs/libchewing/files/0.3.2-fix-crosscompile.patch51
-rw-r--r--dev-libs/libchewing/files/0.3.3-cflags.patch10
-rw-r--r--dev-libs/libchewing/files/0.3.3-tinfo.patch43
-rw-r--r--dev-libs/libchewing/libchewing-0.3.3-r1.ebuild51
6 files changed, 115 insertions, 78 deletions
diff --git a/dev-libs/libchewing/ChangeLog b/dev-libs/libchewing/ChangeLog
index c1952c649b6b..4aa6f78fb38e 100644
--- a/dev-libs/libchewing/ChangeLog
+++ b/dev-libs/libchewing/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/libchewing
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/ChangeLog,v 1.28 2012/10/04 22:35:30 naota Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/ChangeLog,v 1.29 2014/10/26 11:37:50 jer Exp $
+
+*libchewing-0.3.3-r1 (26 Oct 2014)
+
+ 26 Oct 2014; Jeroen Roovers <jer@gentoo.org> +libchewing-0.3.3-r1.ebuild,
+ -files/0.3.2-fix-chewing-zuin-String.patch,
+ -files/0.3.2-fix-crosscompile.patch, +files/0.3.3-cflags.patch,
+ +files/0.3.3-tinfo.patch:
+ Fix building against sys-libs/ncurses[tinfo] (bug #526902). EAPI bump. Remove
+ pointless USE=debug.
04 Oct 2012; <naota@gentoo.org> +files/0.3.3-strncat-fix.patch,
libchewing-0.3.3.ebuild:
diff --git a/dev-libs/libchewing/files/0.3.2-fix-chewing-zuin-String.patch b/dev-libs/libchewing/files/0.3.2-fix-chewing-zuin-String.patch
deleted file mode 100644
index 9f3927bf683b..000000000000
--- a/dev-libs/libchewing/files/0.3.2-fix-chewing-zuin-String.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-commit e33d5e4cfb025f19628cb1e57e59b115af58da5a
-Author: Zach Kuznia <zork@chromium.org>
-Date: Wed Apr 28 17:19:59 2010 -0700
-
- Patch in fix to chewing_zuin_String.
- Add README.chromium
-
- BUG=none
- TEST=none
-
- Review URL: http://codereview.chromium.org/1701019
-
-diff --git a/src/mod_aux.c b/src/mod_aux.c
-index 12936a1..d6d8914 100644
---- a/src/mod_aux.c
-+++ b/src/mod_aux.c
-@@ -90,7 +90,7 @@ CHEWING_API char *chewing_zuin_String( ChewingContext *ctx, int *zuin_count )
- if ( ctx->output->zuinBuf[ i ].s[ 0 ] != '\0' ) {
- strcat( s, (char *) (ctx->output->zuinBuf[ i ].s) );
- if ( zuin_count )
-- *zuin_count++;
-+ (*zuin_count)++;
- }
- }
- return s;
diff --git a/dev-libs/libchewing/files/0.3.2-fix-crosscompile.patch b/dev-libs/libchewing/files/0.3.2-fix-crosscompile.patch
deleted file mode 100644
index bb6054778201..000000000000
--- a/dev-libs/libchewing/files/0.3.2-fix-crosscompile.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-commit 8fbf889dd9a3002926aa0f4958aee10a3ffdf414
-Author: Zach Kuznia <zork@chromium.org>
-Date: Tue Jun 8 09:45:00 2010 +0900
-
- Fix tools to run on the host system during cross-compile.
-
- BUG=chromium-os:3864
- TEST=Set up an arm build environment. Run emerge-arm-generic -a libchewing
-
- Review URL: http://codereview.chromium.org/2640005
-
-diff --git a/configure.ac b/configure.ac
-index c8241d5..035490a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -55,6 +55,9 @@ AC_PROG_CC
- AC_LANG(C)
- AC_C_CONST
-
-+CC_FOR_BUILD=${CC_FOR_BUILD-${CC}}
-+AC_SUBST(CC_FOR_BUILD)
-+
- # Checks if doxygen is avaiable
- AC_PATH_PROG(DOXYGEN, doxygen, no)
- AM_CONDITIONAL(HAVE_DOXYGEN, test x$DOXYGEN != xno)
-diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
-index 8f90595..be2cc0e 100644
---- a/src/tools/Makefile.am
-+++ b/src/tools/Makefile.am
-@@ -4,12 +4,17 @@ INCLUDES = \
- -I$(top_srcdir)/src \
- -I$(top_srcdir)/src/porting_layer/include
-
-+CC = $(CC_FOR_BUILD)
-+CFLAGS = $(CFLAGS_FOR_BUILD)
-+
- noinst_PROGRAMS = sort_word sort_dic maketree
-
--sort_word_LDADD = $(top_builddir)/src/common/libcommon.la
--sort_word_SOURCES = sort_word.c
-+sort_word_SOURCES = sort_word.c \
-+ $(top_builddir)/src/common/key2pho.c \
-+ $(top_builddir)/src/common/chewing-utf8-util.c
-
--sort_dic_LDADD = $(top_builddir)/src/common/libcommon.la
--sort_dic_SOURCES = sort_dic.c
-+sort_dic_SOURCES = sort_dic.c \
-+ $(top_builddir)/src/common/key2pho.c \
-+ $(top_builddir)/src/common/chewing-utf8-util.c
-
- maketree_SOURCES = maketree.c
diff --git a/dev-libs/libchewing/files/0.3.3-cflags.patch b/dev-libs/libchewing/files/0.3.3-cflags.patch
new file mode 100644
index 000000000000..dba1093c5ae6
--- /dev/null
+++ b/dev-libs/libchewing/files/0.3.3-cflags.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -153,7 +122,6 @@
+ if test x$LIBDEBUG = x"true"; then
+ AC_DEFINE(ENABLE_DEBUG, 1,
+ [Define to 1 if you want native library runtime debugging code enabled])
+- CFLAGS="$CFLAGS -g"
+ fi
+ AC_SUBST(LIBDEBUG)
+
diff --git a/dev-libs/libchewing/files/0.3.3-tinfo.patch b/dev-libs/libchewing/files/0.3.3-tinfo.patch
new file mode 100644
index 000000000000..10692e72c8ed
--- /dev/null
+++ b/dev-libs/libchewing/files/0.3.3-tinfo.patch
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -91,38 +91,8 @@
+ AM_CONDITIONAL(ENABLE_UNIT_TEST, test x$enable_check = "xyes")
+
+ # Checks for ncursesw
+-OLDCFLAGS=$CFLAGS
+-LIB_NAME=ncursesw
+-NCURSESW_CFLAGS=
+-NCURSESW_LIBS=
+-for p in "$HOME/include" "$prefix/include" /usr/local/include /usr/include
+-do
+- if test -f "$p/ncursesw/ncurses.h"
+- then
+- NCURSESW_CFLAGS="-I$p"
+- AC_DEFINE(HAVE_NCURSESW_NCURSES_H, 1, [ Define to 1 if you have the <ncursesw/ncurses.h> header file. ])
+- break
+- elif test -f "$p/ncurses/ncurses.h"
+- then
+- NCURSESW_CFLAGS="-I$p"
+- AC_DEFINE(HAVE_NCURSES_NCURSES_H, 1, [ Define to 1 if you have the <ncurses/ncurses.h> header file. ])
+- break
+- fi
+-done
+-
+-for p in "$HOME/lib" "$prefix/lib" /usr/local/lib /usr/lib
+-do
+- if test -f "$p/libncursesw.so"
+- then
+- if test "$p" != x/usr/lib
+- then
+- NCURSESW_LIBS="-L$p -lncursesw"
+- else
+- NCURSESW_LIBS="-lncursesw"
+- fi
+- break
+- fi
+-done
++PKG_CHECK_MODULES(NCURSESW,ncursesw,
++ AC_DEFINE(HAVE_NCURSESW_NCURSES_H, 1, [ Define to 1 if you have the <ncursesw/ncurses.h> header file. ]),)
+
+ enable_ncursesw=yes
+ if test -z "$NCURSESW_CFLAGS"; then
diff --git a/dev-libs/libchewing/libchewing-0.3.3-r1.ebuild b/dev-libs/libchewing/libchewing-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..6d11533e562a
--- /dev/null
+++ b/dev-libs/libchewing/libchewing-0.3.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/libchewing-0.3.3-r1.ebuild,v 1.1 2014/10/26 11:37:50 jer Exp $
+
+EAPI=5
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for Chinese Phonetic input method"
+HOMEPAGE="http://chewing.csie.net/"
+SRC_URI="http://chewing.csie.net/download/libchewing/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs test"
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ sys-libs/ncurses[unicode]
+ >=dev-libs/check-0.9.4
+ )
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-cflags.patch \
+ "${FILESDIR}"/${PV}-strncat-fix.patch \
+ "${FILESDIR}"/${PV}-tinfo.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ # test subdirectory is not enabled by default; this means that we
+ # have to make it explicit.
+ emake -C test check
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_install() {
+ default
+
+ prune_libtool_files
+}