summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:12:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:12:21 +0000
commitfe05733e020e5aef477b9cdc6806e8234da954be (patch)
tree62fac9be2ec80622ff1cc4757fbf9ee822724fb5 /dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild
parent+nsplugin (diff)
downloadgentoo-2-fe05733e020e5aef477b9cdc6806e8234da954be.tar.gz
gentoo-2-fe05733e020e5aef477b9cdc6806e8234da954be.tar.bz2
gentoo-2-fe05733e020e5aef477b9cdc6806e8234da954be.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild')
-rw-r--r--dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild b/dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild
new file mode 100644
index 000000000000..bd2ec8016384
--- /dev/null
+++ b/dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf-binary-locations/cl-asdf-binary-locations-20061018.ebuild,v 1.1 2006/11/09 04:12:21 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="An ASDF-Extension that makes it easy to specify where your Common Lisp binaries (FASL files) should go."
+HOMEPAGE="http://common-lisp.net/project/cl-containers/asdf-binary-locations/"
+SRC_URI="http://common-lisp.net/project/portage-overlay/distfiles/${PN/cl-/}_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-asdf"
+
+S=${WORKDIR}/${PN/cl-/}
+
+CLPACKAGE=asdf-binary-locations
+
+src_install() {
+ insinto $CLSOURCEROOT/$CLPACKAGE/dev
+ doins dev/*.lisp
+ common-lisp-install *.asd
+ common-lisp-system-symlink
+}