summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-09 20:12:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-09 20:12:59 +0000
commit03c58d01244cc881611fd8d8fd1a078ffa7d4234 (patch)
tree96b93eca9e55556f18a3889e2c89285ad9eee2de /dev-lisp/cl-cxml/cl-cxml-20050625.ebuild
parentVersion bump, closes bug #113268. Added patch to avoid running scrollkeeper_u... (diff)
downloadgentoo-2-03c58d01244cc881611fd8d8fd1a078ffa7d4234.tar.gz
gentoo-2-03c58d01244cc881611fd8d8fd1a078ffa7d4234.tar.bz2
gentoo-2-03c58d01244cc881611fd8d8fd1a078ffa7d4234.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-lisp/cl-cxml/cl-cxml-20050625.ebuild')
-rw-r--r--dev-lisp/cl-cxml/cl-cxml-20050625.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lisp/cl-cxml/cl-cxml-20050625.ebuild b/dev-lisp/cl-cxml/cl-cxml-20050625.ebuild
new file mode 100644
index 000000000000..99a917a61f71
--- /dev/null
+++ b/dev-lisp/cl-cxml/cl-cxml-20050625.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cxml/cl-cxml-20050625.ebuild,v 1.1 2005/12/09 20:12:59 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:4}-${PV:4:2}-${PV:6:2}
+
+DESCRIPTION="A Common Lisp XML library implementing namespaces, a validating SAX-like XML 1.0 parser and the DOM Level 1 Core interfaces."
+HOMEPAGE="http://common-lisp.net/project/cxml/"
+SRC_URI="http://common-lisp.net/project/cxml/download/cxml-${MY_PV}.tgz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-puri"
+
+CLPACKAGE='cxml cxml-contrib'
+
+S=${WORKDIR}/cxml-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/GNUmakefile
+}
+
+src_install() {
+ insinto $CLSOURCEROOT/cxml
+ doins *.{dtd,asd} $FILESDIR/cxml-contrib.asd
+ insinto $CLSOURCEROOT/cxml/runes
+ doins runes/*.lisp
+ insinto $CLSOURCEROOT/cxml/xml
+ doins xml/*.lisp
+ insinto $CLSOURCEROOT/cxml/xml/sax-tests
+ doins xml/sax-tests/*.lisp
+ insinto $CLSOURCEROOT/cxml/test
+ doins test/*.lisp
+ insinto $CLSOURCEROOT/cxml/contrib
+ doins contrib/*.lisp
+ insinto $CLSOURCEROOT/cxml/dom
+ doins dom/*.lisp
+ dodir $CLSYSTEMROOT
+ dosym $CLSOURCEROOT/cxml/cxml.asd $CLSYSTEMROOT/
+ dosym $CLSOURCEROOT/cxml/cxml-contrib.asd $CLSYSTEMROOT/
+ dodoc OLDNEWS TIMES
+ dohtml *.{html,css}
+ dohtml -r doc
+}