summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit43e3c27dace2a5d95561cae575e8e8d0dff3f0c5 (patch)
treeb8f70a003c2da92e9f475a0fe908686227fc6069 /dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild
parentBump to 0.5 (Manifest recommit) (diff)
downloadgentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.gz
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.bz2
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild')
-rw-r--r--dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild b/dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild
new file mode 100644
index 000000000000..be676a6e70be
--- /dev/null
+++ b/dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lml2/cl-lml2-1.5.0.ebuild,v 1.1 2004/02/12 09:13:14 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Common Lisp package for generating HTML and XHTML documents"
+HOMEPAGE="http://www.b9.com"
+SRC_URI="ftp://ftp.b9.com/lml2/lml2-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=lml2
+
+S=${WORKDIR}/lml2-${PV}
+
+src_unpack() {
+ unpack ${A}
+ # minor format argument fix (sent to kmr@debian.org Wed Feb 11 2004)
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+}
+src_install() {
+ common-lisp-install *.lisp lml2.asd
+ common-lisp-system-symlink
+ dodoc README LICENSE ChangeLog
+ dohtml doc/readme.html
+ docinto examples
+ dodoc doc/make.lisp doc/Makefile doc/readme.lml
+}