summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit43e3c27dace2a5d95561cae575e8e8d0dff3f0c5 (patch)
treeb8f70a003c2da92e9f475a0fe908686227fc6069 /dev-lisp/cl-uncommonsql
parentBump to 0.5 (Manifest recommit) (diff)
downloadgentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.gz
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.bz2
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-uncommonsql')
-rw-r--r--dev-lisp/cl-uncommonsql/ChangeLog9
-rw-r--r--dev-lisp/cl-uncommonsql/Manifest7
-rw-r--r--dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.1-r1.ebuild58
-rw-r--r--dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.1-r11
4 files changed, 70 insertions, 5 deletions
diff --git a/dev-lisp/cl-uncommonsql/ChangeLog b/dev-lisp/cl-uncommonsql/ChangeLog
index 1337b2ab23e2..3cc8fa2bedce 100644
--- a/dev-lisp/cl-uncommonsql/ChangeLog
+++ b/dev-lisp/cl-uncommonsql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-uncommonsql
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uncommonsql/ChangeLog,v 1.3 2003/10/17 19:02:59 mkennedy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uncommonsql/ChangeLog,v 1.4 2004/02/12 09:13:21 mkennedy Exp $
+
+*cl-uncommonsql-1.2.1-r1 (12 Feb 2004)
+
+ 12 Feb 2004; <mkennedy@gentoo.org> cl-uncommonsql-1.2.1-r1.ebuild:
+ Cleanup for eclass changes.
17 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org>
cl-uncommonsql-1.2.1.ebuild:
diff --git a/dev-lisp/cl-uncommonsql/Manifest b/dev-lisp/cl-uncommonsql/Manifest
index 709724b4e145..f36c68cfcfa3 100644
--- a/dev-lisp/cl-uncommonsql/Manifest
+++ b/dev-lisp/cl-uncommonsql/Manifest
@@ -1,6 +1,7 @@
-MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 f61588d49b2ed49b1e1e918bbe772751 ChangeLog 628
-MD5 06b475ddb3a414de7681b1b19f0b9111 cl-uncommonsql-1.2.1.ebuild 2719
+MD5 b9cd91f64ce7b353656c5c27bfe11c3e cl-uncommonsql-1.2.1-r1.ebuild 2258
MD5 5ea6cf105716f7fab9f4aee72bd703c5 cl-uncommonsql-1.2.0.ebuild 1315
+MD5 f61588d49b2ed49b1e1e918bbe772751 ChangeLog 628
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 b1de4fe856dd6fba62cf838680f53de2 files/digest-cl-uncommonsql-1.2.0 77
MD5 81c341abb2556659cf373cf6b22ea331 files/digest-cl-uncommonsql-1.2.1 77
+MD5 81c341abb2556659cf373cf6b22ea331 files/digest-cl-uncommonsql-1.2.1-r1 77
diff --git a/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.1-r1.ebuild b/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..34de5ad76d77
--- /dev/null
+++ b/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uncommonsql/cl-uncommonsql-1.2.1-r1.ebuild,v 1.1 2004/02/12 09:13:21 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="UncommonSQL is a database integration kit for Common Lisp. It provides a CommonSQL-compatible interface with a functional SQL syntax and a CLOS integrated Object-to-Relational mapping. You can serialize complete CLOS objects into an RDBMS."
+HOMEPAGE="http://alpha.onshored.com/lisp-software/#uncommonsql"
+SRC_URI="http://alpha.onshored.com/debian/local/${PN}_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="postgres mysql"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cl-odcl
+ virtual/commonlisp
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )"
+
+CLPACKAGE=uncommonsql
+
+use postgres && CLPACKAGE="${CLPACKAGE} uncommonsql-postgresql"
+use mysql && CLPACKAGE="${CLPACKAGE} uncommonsql-mysql"
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/uncommonsql
+ doins *.lisp uncommonsql.system
+ insinto /usr/share/common-lisp/source/uncommonsql/sql
+ doins sql/*.lisp
+ insinto /usr/share/common-lisp/source/uncommonsql/sql/tests
+ doins sql/tests/*.lisp
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/uncommonsql/uncommonsql.system \
+ /usr/share/common-lisp/systems/uncommonsql.system
+ dodoc CONTRIB* COPYING ChangeLog INSTALL README VERSION TODO
+
+ if use postgres; then
+ insinto /usr/share/common-lisp/source/uncommonsql/dbms/postgresql
+ doins dbms/postgresql/*.lisp
+ dosym /usr/share/common-lisp/source/uncommonsql \
+ /usr/share/common-lisp/source/uncommonsql-postgresql
+ dodir /usr/share/common-lisp/systems
+ grep -v mk:oos dbms/postgresql/system.lisp \
+ >${D}/usr/share/common-lisp/systems/uncommonsql-postgresql.system
+ fi
+
+ if use mysql; then
+ insinto /usr/share/common-lisp/source/uncommonsql/dbms/mysql
+ doins dbms/mysql/*.lisp
+ dosym /usr/share/common-lisp/source/uncommonsql \
+ /usr/share/common-lisp/source/uncommonsql-mysql
+ dodir /usr/share/common-lisp/systems
+ grep -v mk:oos dbms/mysql/system.lisp \
+ >${D}/usr/share/common-lisp/systems/uncommonsql-mysql.system
+ fi
+}
diff --git a/dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.1-r1 b/dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.1-r1
new file mode 100644
index 000000000000..efe1ef42afbe
--- /dev/null
+++ b/dev-lisp/cl-uncommonsql/files/digest-cl-uncommonsql-1.2.1-r1
@@ -0,0 +1 @@
+MD5 b99a5c4a73f33a20b5173b7177cc4170 cl-uncommonsql_1.2.1.orig.tar.gz 137942