summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-26 20:23:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-26 20:23:32 +0000
commit329b095530846ea1b97bc142d5fad8d97e88ec10 (patch)
tree3d583b01e5223058bc634c25252d548d653a5fd4 /dev-lisp/cl-zpb-ttf
parentStable on amd64. Bug #90793. (diff)
downloadgentoo-2-329b095530846ea1b97bc142d5fad8d97e88ec10.tar.gz
gentoo-2-329b095530846ea1b97bc142d5fad8d97e88ec10.tar.bz2
gentoo-2-329b095530846ea1b97bc142d5fad8d97e88ec10.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.1_pre5)
Diffstat (limited to 'dev-lisp/cl-zpb-ttf')
-rw-r--r--dev-lisp/cl-zpb-ttf/ChangeLog10
-rw-r--r--dev-lisp/cl-zpb-ttf/Manifest9
-rw-r--r--dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild27
-rw-r--r--dev-lisp/cl-zpb-ttf/files/digest-cl-zpb-ttf-0.33
-rw-r--r--dev-lisp/cl-zpb-ttf/metadata.xml5
5 files changed, 54 insertions, 0 deletions
diff --git a/dev-lisp/cl-zpb-ttf/ChangeLog b/dev-lisp/cl-zpb-ttf/ChangeLog
new file mode 100644
index 000000000000..427389028aad
--- /dev/null
+++ b/dev-lisp/cl-zpb-ttf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-zpb-ttf
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-zpb-ttf/ChangeLog,v 1.1 2006/02/26 20:23:32 mkennedy Exp $
+
+*cl-zpb-ttf-0.3 (26 Feb 2006)
+
+ 26 Feb 2006; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-zpb-ttf-0.3.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-zpb-ttf/Manifest b/dev-lisp/cl-zpb-ttf/Manifest
new file mode 100644
index 000000000000..89446a8184c0
--- /dev/null
+++ b/dev-lisp/cl-zpb-ttf/Manifest
@@ -0,0 +1,9 @@
+MD5 263ae1dc91ad58176d830fba085ba928 cl-zpb-ttf-0.3.ebuild 691
+RMD160 3d2e4666f1dea8fb5baaeb3f472d1b30e733d732 cl-zpb-ttf-0.3.ebuild 691
+SHA256 0f3680d9e91267b5cfb38a539f3a43c6be00650ec44ca1fc810ac2065d3cf0c1 cl-zpb-ttf-0.3.ebuild 691
+MD5 e44bff4a84ec5027ee7ab9e45ab39feb files/digest-cl-zpb-ttf-0.3 223
+RMD160 d99ffe227cb6524ef035f042855098063f9a9fd4 files/digest-cl-zpb-ttf-0.3 223
+SHA256 9c26b34ff52c26171ba77b9f77cce09aae593c570b0a161da4d47b457b41a016 files/digest-cl-zpb-ttf-0.3 223
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+RMD160 5edb79931b874dc3a72128f0742b9d4c4eb3c8c1 metadata.xml 164
+SHA256 f8efc9385015233c71f279f85bd0a327525b7136cf8714cc04449d8bea4ce22f metadata.xml 164
diff --git a/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild b/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild
new file mode 100644
index 000000000000..639d00c61e5a
--- /dev/null
+++ b/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-zpb-ttf/cl-zpb-ttf-0.3.ebuild,v 1.1 2006/02/26 20:23:32 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="TrueType font file access library for Common Lisp"
+HOMEPAGE="http://www.xach.com/lisp/zpb-ttf/"
+SRC_URI="mirror://gentoo/zpb-ttf-${PV}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~ppc"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+S=${WORKDIR}/zpb-ttf-${PV}
+
+CLPACKAGE=zpb-ttf
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dohtml *.{html,png}
+ dodoc LICENSE
+}
diff --git a/dev-lisp/cl-zpb-ttf/files/digest-cl-zpb-ttf-0.3 b/dev-lisp/cl-zpb-ttf/files/digest-cl-zpb-ttf-0.3
new file mode 100644
index 000000000000..5f45571c4d70
--- /dev/null
+++ b/dev-lisp/cl-zpb-ttf/files/digest-cl-zpb-ttf-0.3
@@ -0,0 +1,3 @@
+MD5 1273dde84c137da6c3344ea7b5f1a25a zpb-ttf-0.3.tgz 47069
+RMD160 d64f32316913981871b96e5bec6e516e4fba779e zpb-ttf-0.3.tgz 47069
+SHA256 0d5eeeade13a37d063399de664857ae267082aa4d553ac8552270982844ac032 zpb-ttf-0.3.tgz 47069
diff --git a/dev-lisp/cl-zpb-ttf/metadata.xml b/dev-lisp/cl-zpb-ttf/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-zpb-ttf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>