summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-08-12 13:26:02 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-08-12 13:26:02 +0000
commit64b00641fdd2c4c9a44b6a34c82dd7c127f13eac (patch)
tree379ac40a9c677297f3ef229dc9ed1e2150e71b4d /dev-lisp/ecls
parentfixed symlinks. (diff)
downloadgentoo-2-64b00641fdd2c4c9a44b6a34c82dd7c127f13eac.tar.gz
gentoo-2-64b00641fdd2c4c9a44b6a34c82dd7c127f13eac.tar.bz2
gentoo-2-64b00641fdd2c4c9a44b6a34c82dd7c127f13eac.zip
Initial import
Diffstat (limited to 'dev-lisp/ecls')
-rw-r--r--dev-lisp/ecls/ecls-0.2.ebuild63
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.21
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.31
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-lisp/ecls/ecls-0.2.ebuild b/dev-lisp/ecls/ecls-0.2.ebuild
new file mode 100644
index 000000000000..c335a4cb2c8f
--- /dev/null
+++ b/dev-lisp/ecls/ecls-0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $header:$
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Embeddable Common Lisp 'Spain'"
+SRC_URI="http://prdownloads.sourceforge.net/ecls/ecls-0.2.tgz"
+
+PROVIDE="virtual/commonlisp"
+
+src_unpack() {
+
+ unpack ${P}.tgz
+
+# mv ${WORKDIR}/ecls-0.2 ${S}
+}
+
+src_compile() {
+
+ local myconf
+
+ cd ${S}
+
+ if [ "`use X`" ]
+ then
+ myopts="${myconf} --with-x"
+ else
+ myopts="${myconf} --with-x=no"
+ fi
+
+ echo ${CXXFLAGS} ${CFLAGS} ${LSPCFLAGS}
+ try ./configure --prefix=/usr $myopts
+
+ #
+ # FIXME: This really needs to be triple-verified
+ #
+ local mcpu=`echo ${CFLAGS} | sed "s/.*-mcpu=\([a-zA-Z0-9]*\).*/\1/g"`
+ local march=`echo ${CFLAGS} | sed "s/.*-march=\([a-zA-Z0-9]*\).*/\1/g"`
+
+ echo ${mcpu} -- ${march}
+
+ for i in build/{crs,c,gc,tk,.}/Makefile ; do
+ cp $i $i.orig ;
+ cat $i.orig | sed -e "s:-mcpu= 1:-mcpu=${mcpu}:g" | sed -e "s:-march= 1:-march=${march}:g" > $i ;
+ done
+
+ cp build/gabriel/Makefile build/gabriel/Makefile.orig
+ cat build/gabriel/Makefile.orig | sed "s/FILES =.*/FILES = ECLSc ECLSi/g" > build/gabriel/Makefile
+
+ touch LGPL
+
+ alias lisp='echo NOT INSTALLED!'
+ echo ${CXXFLAGS} ${CFLAGS}
+ try make
+
+}
+
+src_install() {
+
+ try make install PREFIX=${D}/usr
+
+}
diff --git a/dev-lisp/ecls/files/digest-ecls-0.2 b/dev-lisp/ecls/files/digest-ecls-0.2
new file mode 100644
index 000000000000..8c644b12f7da
--- /dev/null
+++ b/dev-lisp/ecls/files/digest-ecls-0.2
@@ -0,0 +1 @@
+MD5 6ecaa338c3a3224a172719eeac77d2e1 ecls-0.2.tgz
diff --git a/dev-lisp/ecls/files/digest-ecls-0.3 b/dev-lisp/ecls/files/digest-ecls-0.3
new file mode 100644
index 000000000000..b3ad05e17aa4
--- /dev/null
+++ b/dev-lisp/ecls/files/digest-ecls-0.3
@@ -0,0 +1 @@
+MD5 7ba12dbd9e30f9ceb1f8091190426abd ecls.tgz