summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-21 19:05:24 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-21 19:05:24 +0000
commit3c8b11996d56caa8c70cc2cc6c2a1b747c5ae67a (patch)
treeb7fddd07d28ec8992f49e7c72cae82bb908353f8 /dev-ml/extlib/extlib-1.2.ebuild
parent<fpc-source> I don't like anything above -j1. <ChrisWhite> why me! Fixing so... (diff)
downloadgentoo-2-3c8b11996d56caa8c70cc2cc6c2a1b747c5ae67a.tar.gz
gentoo-2-3c8b11996d56caa8c70cc2cc6c2a1b747c5ae67a.tar.bz2
gentoo-2-3c8b11996d56caa8c70cc2cc6c2a1b747c5ae67a.zip
Initial import, fix bug #60917
Diffstat (limited to 'dev-ml/extlib/extlib-1.2.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.2.ebuild b/dev-ml/extlib/extlib-1.2.ebuild
new file mode 100644
index 000000000000..2c8e920b66db
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.2.ebuild,v 1.1 2004/08/21 19:05:24 mattam Exp $
+
+inherit findlib
+
+MY_P=extLib-${PV}
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://ocaml-lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ocaml-lib/${MY_P}.tgz"
+
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.07"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ sed -i -e "s/IOO//" Makefile
+ make all opt
+
+ if use doc; then
+ make doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}