summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-03 14:48:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-03 14:48:44 +0000
commit5ba020dcef62cf91f27aa3223b1429caf1040d8e (patch)
tree43dfd9a16e89361f58ef3dcf762d9236f5b69946 /dev-ml/ocamlsdl
parentremove old (diff)
downloadgentoo-2-5ba020dcef62cf91f27aa3223b1429caf1040d8e.tar.gz
gentoo-2-5ba020dcef62cf91f27aa3223b1429caf1040d8e.tar.bz2
gentoo-2-5ba020dcef62cf91f27aa3223b1429caf1040d8e.zip
eapi5: define subslot and use slot deps. cosmetics.
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlsdl')
-rw-r--r--dev-ml/ocamlsdl/ChangeLog5
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild37
2 files changed, 24 insertions, 18 deletions
diff --git a/dev-ml/ocamlsdl/ChangeLog b/dev-ml/ocamlsdl/ChangeLog
index b53bbce0d743..428d2a4534ee 100644
--- a/dev-ml/ocamlsdl/ChangeLog
+++ b/dev-ml/ocamlsdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocamlsdl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ChangeLog,v 1.23 2013/03/03 14:44:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ChangeLog,v 1.24 2013/03/03 14:48:44 aballier Exp $
+
+ 03 Mar 2013; Alexis Ballier <aballier@gentoo.org> ocamlsdl-0.9.1.ebuild:
+ eapi5: define subslot and use slot deps. cosmetics.
03 Mar 2013; Alexis Ballier <aballier@gentoo.org> -ocamlsdl-0.8.0.ebuild,
-ocamlsdl-0.9.0.ebuild:
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
index 8081a7105f27..b70eda7b3b02 100644
--- a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild,v 1.3 2012/11/20 20:51:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild,v 1.4 2013/03/03 14:48:44 aballier Exp $
+
+EAPI=5
inherit findlib
@@ -10,18 +12,21 @@ HOMEPAGE="http://ocamlsdl.sourceforge.net"
SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
LICENSE="LGPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ppc x86"
IUSE="doc opengl truetype" #noimage nomixer
-DEPEND=">=dev-lang/ocaml-3.04
->=media-libs/libsdl-1.2
-opengl? ( >=dev-ml/lablgl-0.98 )
->=media-libs/sdl-mixer-1.2
->=media-libs/sdl-image-1.2
-truetype? ( >=media-libs/sdl-ttf-2.0 )"
-
-src_compile() {
+RDEPEND="
+ >=dev-lang/ocaml-3.04:=
+ >=media-libs/libsdl-1.2
+ opengl? ( >=dev-ml/lablgl-0.98:= )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ truetype? ( >=media-libs/sdl-ttf-2.0 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
myconf=""
if use opengl; then
destdir=`ocamlfind printconf destdir`
@@ -40,18 +45,16 @@ src_compile() {
#use nomixer && myconf="${myconf} --without-sdl-mixer"
econf $myconf \
- `use_enable truetype sdl-ttf` \
- || die
- emake all || die
+ `use_enable truetype sdl-ttf`
}
src_install() {
findlib_src_install
- dodoc AUTHORS NEWS README || die
- doinfo doc/*.info* || die
+ dodoc AUTHORS NEWS README
+ doinfo doc/*.info*
if use doc; then
- dohtml doc/html/* || die
+ dohtml doc/html/*
fi
}