summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-12 07:00:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-12 07:00:08 +0000
commit33d642f39c3c05e2e2cf6adc6adea9859eb07803 (patch)
tree3f94a1b7a3b4f2c2cd827c265bb88c4411bde97f /dev-ml/pcre-ocaml
parentversion bump (diff)
downloadgentoo-2-33d642f39c3c05e2e2cf6adc6adea9859eb07803.tar.gz
gentoo-2-33d642f39c3c05e2e2cf6adc6adea9859eb07803.tar.bz2
gentoo-2-33d642f39c3c05e2e2cf6adc6adea9859eb07803.zip
version bump
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog8
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-5.15.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 49ed122ba3fd..e6bf26648e61 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.18 2008/05/12 06:51:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.19 2008/05/12 07:00:08 aballier Exp $
+
+*pcre-ocaml-5.15.0 (12 May 2008)
+
+ 12 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-5.15.0.ebuild:
+ version bump
12 May 2008; Alexis Ballier <aballier@gentoo.org>
-pcre-ocaml-5.12.1.ebuild, -pcre-ocaml-5.12.2.ebuild,
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-5.15.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-5.15.0.ebuild
new file mode 100644
index 000000000000..da411c524f09
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-5.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-5.15.0.ebuild,v 1.1 2008/05/12 07:00:08 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07
+ >=dev-libs/libpcre-4.5"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README VERSION Changes
+
+ if use examples; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+}