summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-09-21 20:15:06 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-09-21 20:15:06 +0000
commitd37ca63c66c8057917f6a83fcbd62192c12e9e98 (patch)
treec9caad5ab5793da52491a8adcb4236f041ff29e1 /dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild
parentmark stable on x86 (diff)
downloadgentoo-2-d37ca63c66c8057917f6a83fcbd62192c12e9e98.tar.gz
gentoo-2-d37ca63c66c8057917f6a83fcbd62192c12e9e98.tar.bz2
gentoo-2-d37ca63c66c8057917f6a83fcbd62192c12e9e98.zip
New ebuild, postgresql bindings for ocaml.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild
new file mode 100644
index 000000000000..58ac3f1feec4
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.4.6.ebuild,v 1.1 2005/09/21 20:15:06 mattam Exp $
+
+inherit findlib
+
+IUSE=""
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.07
+>=dev-db/postgresql-7.3"
+RDEPEND=">=dev-lang/ocaml-3.06"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ~ppc"
+
+src_compile()
+{
+ emake CFLAGS=-I/usr/include/postgresql/pgsql
+}
+
+src_install()
+{
+ findlib_src_preinst
+ make DESTDIR=${D} install || die
+
+ if use doc; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+
+ dodoc INSTALL AUTHORS VERSION
+}