summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-23 18:46:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-23 18:46:17 +0000
commit3609013a4860c3e8d9be112bd94f06743132828d (patch)
treee834a0e630dc141c4eaf572cf4cb17ac8291465a /dev-ml
parentVersion bump. (diff)
downloadgentoo-2-3609013a4860c3e8d9be112bd94f06743132828d.tar.gz
gentoo-2-3609013a4860c3e8d9be112bd94f06743132828d.tar.bz2
gentoo-2-3609013a4860c3e8d9be112bd94f06743132828d.zip
Non maintainer update: Install it in a proper subdir not to pollute ocaml namespace, bug #454660. Eapi-5: Define subslot and add slot deps on ocaml. Install a META file for findlib. Remove useless dep on the OCaml reference manual.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/xml-light/ChangeLog12
-rw-r--r--dev-ml/xml-light/xml-light-2.2-r2.ebuild51
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-ml/xml-light/ChangeLog b/dev-ml/xml-light/ChangeLog
index 8982fadd6634..b4431a243bb1 100644
--- a/dev-ml/xml-light/ChangeLog
+++ b/dev-ml/xml-light/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ml/xml-light
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/xml-light/ChangeLog,v 1.7 2012/06/10 04:52:42 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/xml-light/ChangeLog,v 1.8 2013/07/23 18:46:17 aballier Exp $
+
+*xml-light-2.2-r2 (23 Jul 2013)
+
+ 23 Jul 2013; Alexis Ballier <aballier@gentoo.org> +xml-light-2.2-r2.ebuild:
+ Non maintainer update: Install it in a proper subdir not to pollute ocaml
+ namespace, bug #454660. Eapi-5: Define subslot and add slot deps on ocaml.
+ Install a META file for findlib. Remove useless dep on the OCaml reference
+ manual.
10 Jun 2012; Jeff Horelick <jdhore@gentoo.org> xml-light-2.2-r1.ebuild:
marked x86 per bug 419417
diff --git a/dev-ml/xml-light/xml-light-2.2-r2.ebuild b/dev-ml/xml-light/xml-light-2.2-r2.ebuild
new file mode 100644
index 000000000000..72faa56fd80d
--- /dev/null
+++ b/dev-ml/xml-light/xml-light-2.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/xml-light/xml-light-2.2-r2.ebuild,v 1.1 2013/07/23 18:46:17 aballier Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Minimal Xml parser and printer for OCaml"
+HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
+SRC_URI="http://tech.motion-twin.com/zip/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=dpatch EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+}
+
+src_compile() {
+ emake -j1
+ if use doc;then
+ emake doc
+ fi
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/ocaml/${PN}
+ emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} install
+ cat > "${D}"/usr/$(get_libdir)/ocaml/${PN}/META << EOF
+name="${PN}"
+version="${PV}"
+description="${DESCRIPTION}"
+requires=""
+archive(byte) = "xml-light.cma"
+EOF
+ dodoc README
+ if use doc; then
+ emake doc
+ dohtml doc/*
+ fi
+}