summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-06-20 01:09:22 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-06-20 01:09:22 +0000
commit3b09ded4a937e920a473461443fd3cdfa94312ed (patch)
tree4acc021f9444a64dc072932f228f739b335717ec /dev-ml
parentnew package - a generic Makefile for simplification of ocaml Makefiles (diff)
downloadgentoo-2-3b09ded4a937e920a473461443fd3cdfa94312ed.tar.gz
gentoo-2-3b09ded4a937e920a473461443fd3cdfa94312ed.tar.bz2
gentoo-2-3b09ded4a937e920a473461443fd3cdfa94312ed.zip
new package - a generic Makefile for simplification of ocaml Makefiles
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-make/ChangeLog10
-rw-r--r--dev-ml/ocaml-make/Manifest3
-rw-r--r--dev-ml/ocaml-make/files/digest-ocaml-make-5.04.01
-rw-r--r--dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild29
4 files changed, 42 insertions, 1 deletions
diff --git a/dev-ml/ocaml-make/ChangeLog b/dev-ml/ocaml-make/ChangeLog
new file mode 100644
index 000000000000..c8e955272ba8
--- /dev/null
+++ b/dev-ml/ocaml-make/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/ocaml-make
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ChangeLog,v 1.1 2003/06/20 01:09:11 george Exp $
+
+*ocaml-make-5.04.0.ebuild (19 Jun 2003)
+
+ 19 Jun 2003; George Shapovalov <george@gentoo.org> Manifest, ocaml-make-5.04.0.ebuild, files/{digest-ocaml-make-5.04.0} :
+ initial release (#22279)
+ Generic O'Caml Makefile for GNU Make
+ ebuild submitted by Bardur Arantsson <bardur-gta@odense.kollegienet.dk>
diff --git a/dev-ml/ocaml-make/Manifest b/dev-ml/ocaml-make/Manifest
index c949edecc62e..c9f9f65da934 100644
--- a/dev-ml/ocaml-make/Manifest
+++ b/dev-ml/ocaml-make/Manifest
@@ -1,2 +1,3 @@
-MD5 395a11f882ff211528f7fc610cd4cb6a ocaml-make-5.04.0.ebuild 714
+MD5 482a4e3887ee51222472a9edc0a8d76e ocaml-make-5.04.0.ebuild 819
+MD5 411bd62f92f1e321a058badc8a8cfaaf ChangeLog 513
MD5 54d2d16a1fee2369b565dc8dc673ebc3 files/digest-ocaml-make-5.04.0 69
diff --git a/dev-ml/ocaml-make/files/digest-ocaml-make-5.04.0 b/dev-ml/ocaml-make/files/digest-ocaml-make-5.04.0
new file mode 100644
index 000000000000..d00e0ed37420
--- /dev/null
+++ b/dev-ml/ocaml-make/files/digest-ocaml-make-5.04.0
@@ -0,0 +1 @@
+MD5 a2ca22de38a1097670bbc93f43394a74 ocaml-make-5.04.0.tar.bz2 28345
diff --git a/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild b/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild
new file mode 100644
index 000000000000..38862fbf96de
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild,v 1.1 2003/06/20 01:09:11 george Exp $
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # Nothing to do
+ echo -n
+}
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc LICENSE README Changes
+}