summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-19 13:18:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-19 13:18:26 +0000
commit3e375138e9a6f80d5d96018009c030668609f917 (patch)
tree7200dd312bec886ab86253df0f3cc5cf1f791443 /dev-ml
parentremove old (diff)
downloadgentoo-2-3e375138e9a6f80d5d96018009c030668609f917.tar.gz
gentoo-2-3e375138e9a6f80d5d96018009c030668609f917.tar.bz2
gentoo-2-3e375138e9a6f80d5d96018009c030668609f917.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog9
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.0.4.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 62bfdd00d131..00b0bc76f2df 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.52 2013/08/26 15:07:27 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.53 2014/01/19 13:18:26 aballier Exp $
+
+*pcre-ocaml-7.0.4 (19 Jan 2014)
+
+ 19 Jan 2014; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-7.0.4.ebuild:
+ version bump
26 Aug 2013; Alexis Ballier <aballier@gentoo.org> pcre-ocaml-7.0.2.ebuild:
depend on ocaml 4, bug #482182
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.0.4.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.0.4.ebuild
new file mode 100644
index 000000000000..a9983d3e3f1a
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-7.0.4.ebuild,v 1.1 2014/01/19 13:18:26 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/pcre-ocaml"
+SRC_URI="http://bitbucket.org/mmottl/pcre-ocaml/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}