summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-09 00:52:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-09 00:52:50 +0000
commit59dcc366a93d89677ec3a329c852a37d616f0fa7 (patch)
tree34f7c4b2acee2e756a45b5fa8afedaee81a90c12 /dev-ml
parentapgdiff: version bump (diff)
downloadgentoo-2-59dcc366a93d89677ec3a329c852a37d616f0fa7.tar.gz
gentoo-2-59dcc366a93d89677ec3a329c852a37d616f0fa7.tar.bz2
gentoo-2-59dcc366a93d89677ec3a329c852a37d616f0fa7.zip
version bump
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ounit/ChangeLog9
-rw-r--r--dev-ml/ounit/ounit-1.1.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index b38fd7781049..7d96b486527c 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ounit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.19 2009/09/28 16:26:13 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.20 2010/10/09 00:52:50 aballier Exp $
+
+*ounit-1.1.0 (09 Oct 2010)
+
+ 09 Oct 2010; Alexis Ballier <aballier@gentoo.org> +ounit-1.1.0.ebuild:
+ version bump
28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> ounit-1.0.3.ebuild:
Migrate to EAPI 2 in order to nuke built_with_use.
diff --git a/dev-ml/ounit/ounit-1.1.0.ebuild b/dev-ml/ounit/ounit-1.1.0.ebuild
new file mode 100644
index 000000000000..79e291baf453
--- /dev/null
+++ b/dev-ml/ounit/ounit-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.1.0.ebuild,v 1.1 2010/10/09 00:52:50 aballier Exp $
+
+EAPI="2"
+
+inherit findlib multilib
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="http://ounit.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/495/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+IUSE="debug doc +ocamlopt"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ chmod +x configure
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README* AUTHORS* changelog || die
+}