summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-07 16:33:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-07 16:33:18 +0000
commit8846a03cc60ff08f50dc889baeba6c8220de8b4a (patch)
treed79f2d14d46ce86544753604e5ed4f42810bc38a /dev-ml
parentVersion bump. (diff)
downloadgentoo-2-8846a03cc60ff08f50dc889baeba6c8220de8b4a.tar.gz
gentoo-2-8846a03cc60ff08f50dc889baeba6c8220de8b4a.tar.bz2
gentoo-2-8846a03cc60ff08f50dc889baeba6c8220de8b4a.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/findlib-1.2.6.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 28fa9346509a..a9325e4d32b5 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.63 2010/11/05 18:23:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.64 2010/11/07 16:33:18 aballier Exp $
+
+*findlib-1.2.6 (07 Nov 2010)
+
+ 07 Nov 2010; Alexis Ballier <aballier@gentoo.org> +findlib-1.2.6.ebuild:
+ version bump
05 Nov 2010; Markos Chandras <hwoarang@gentoo.org> findlib-1.2.5.ebuild:
Stable on amd64 wrt bug #343751
diff --git a/dev-ml/findlib/findlib-1.2.6.ebuild b/dev-ml/findlib/findlib-1.2.6.ebuild
new file mode 100644
index 000000000000..c1a4f49efea1
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.2.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.6.ebuild,v 1.1 2010/11/07 16:33:18 aballier Exp $
+
+EAPI=2
+
+inherit multilib
+
+RESTRICT="installsources"
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?,tk?]"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake all || die
+ if use ocamlopt; then
+ emake opt || die # optimized code
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ dodir `ocamlc -where`
+
+ emake prefix="${D}" install || die
+
+ dodir "${stublibs}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}