summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-06-05 13:27:12 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-06-05 13:27:12 +0000
commitff0a83cd3b71331ea2c1327a18cdccf40182c7d0 (patch)
tree443759c34a86fdea44bca1ac7baf810427e386f1 /dev-perl/Apache-Gallery
parentdep fixes (Manifest recommit) (diff)
downloadgentoo-2-ff0a83cd3b71331ea2c1327a18cdccf40182c7d0.tar.gz
gentoo-2-ff0a83cd3b71331ea2c1327a18cdccf40182c7d0.tar.bz2
gentoo-2-ff0a83cd3b71331ea2c1327a18cdccf40182c7d0.zip
new version, new deps
Diffstat (limited to 'dev-perl/Apache-Gallery')
-rw-r--r--dev-perl/Apache-Gallery/Apache-Gallery-0.8.ebuild61
-rw-r--r--dev-perl/Apache-Gallery/ChangeLog10
-rw-r--r--dev-perl/Apache-Gallery/Manifest4
-rw-r--r--dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.81
4 files changed, 73 insertions, 3 deletions
diff --git a/dev-perl/Apache-Gallery/Apache-Gallery-0.8.ebuild b/dev-perl/Apache-Gallery/Apache-Gallery-0.8.ebuild
new file mode 100644
index 000000000000..8b16029e61d1
--- /dev/null
+++ b/dev-perl/Apache-Gallery/Apache-Gallery-0.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Gallery/Apache-Gallery-0.8.ebuild,v 1.1 2004/06/05 13:27:12 mcummings Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://cpan.org/modules/by-module/Apache/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/LEGART/${P}"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="~x86"
+
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/mod_perl-1.27-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ dev-perl/Image-Imlib2
+ >=dev-perl/CGI-2.78-r3
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ >=dev-perl/Inline-0.43-r1
+ >=x11-base/xfree-4.2.1
+ "
+
+
+
+src_install() {
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto /home/httpd/icons
+ doins htdocs/*.png
+
+ insinto /etc/apache/gallery/templates
+ doins templates/*.tpl
+
+ insinto /etc/apache/conf
+ doins ${FILESDIR}/apache-gallery.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated."
+ einfo "You should then edit your /etc/apache/conf/apache-gallery.conf file to suit."
+ einfo
+}
+
+pkg_config() {
+ echo "Include conf/apache-gallery.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/dev-perl/Apache-Gallery/ChangeLog b/dev-perl/Apache-Gallery/ChangeLog
index d6d7cdaef854..8ed397a18608 100644
--- a/dev-perl/Apache-Gallery/ChangeLog
+++ b/dev-perl/Apache-Gallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Apache-Gallery
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Gallery/ChangeLog,v 1.2 2003/07/29 15:51:19 mcummings Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Gallery/ChangeLog,v 1.3 2004/06/05 13:27:12 mcummings Exp $
+
+*Apache-Gallery-0.8 (05 Jun 2004)
+
+ 05 Jun 2004; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.8.ebuild:
+ new version, new deps
29 Jul 2003; Michael Cummings <mcummings@gentoo.org>
files/apache-gallery.conf:
diff --git a/dev-perl/Apache-Gallery/Manifest b/dev-perl/Apache-Gallery/Manifest
index e3122e98a84a..59f4816dec9e 100644
--- a/dev-perl/Apache-Gallery/Manifest
+++ b/dev-perl/Apache-Gallery/Manifest
@@ -1,5 +1,7 @@
MD5 a33d019991027ae3b2644a1f00a7559d Apache-Gallery-0.6.ebuild 1483
MD5 399f38d97f6427ba0028bd9a24f5d5e1 ChangeLog 654
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
-MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
+MD5 a33d019991027ae3b2644a1f00a7559d Apache-Gallery-0.8.ebuild 1483
MD5 d7306e4a4568b0c242ef3b73d3ad0e4e files/apache-gallery.conf 719
+MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
+MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8 69
diff --git a/dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.8 b/dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.8
new file mode 100644
index 000000000000..751d21f9d580
--- /dev/null
+++ b/dev-perl/Apache-Gallery/files/digest-Apache-Gallery-0.8
@@ -0,0 +1 @@
+MD5 c04d7d8edc90982eae68a431077f9413 Apache-Gallery-0.8.tar.gz 77184