summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-08-16 08:13:25 +0000
committerTorsten Veller <tove@gentoo.org>2009-08-16 08:13:25 +0000
commit2eb5b7a33db0a7708b259c1fe20b7061d4655156 (patch)
tree3562db13bc6d9258ed1e8cfba6f64624366cd04c /dev-perl/AppConfig
parentVersion bump. Skip locking test (#279960). (diff)
downloadgentoo-2-2eb5b7a33db0a7708b259c1fe20b7061d4655156.tar.gz
gentoo-2-2eb5b7a33db0a7708b259c1fe20b7061d4655156.tar.bz2
gentoo-2-2eb5b7a33db0a7708b259c1fe20b7061d4655156.zip
Cleanup. Remove old patch
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/AppConfig')
-rw-r--r--dev-perl/AppConfig/AppConfig-1.66.ebuild19
-rw-r--r--dev-perl/AppConfig/ChangeLog8
-rw-r--r--dev-perl/AppConfig/files/blocksep.patch74
-rw-r--r--dev-perl/AppConfig/files/blockwhitespace.patch12
4 files changed, 15 insertions, 98 deletions
diff --git a/dev-perl/AppConfig/AppConfig-1.66.ebuild b/dev-perl/AppConfig/AppConfig-1.66.ebuild
index ea5739e95b53..ff2a8f0babc3 100644
--- a/dev-perl/AppConfig/AppConfig-1.66.ebuild
+++ b/dev-perl/AppConfig/AppConfig-1.66.ebuild
@@ -1,22 +1,21 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/AppConfig-1.66.ebuild,v 1.6 2008/10/27 16:22:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/AppConfig-1.66.ebuild,v 1.7 2009/08/16 08:13:24 tove Exp $
+EAPI=2
+
+MODULE_AUTHOR=ABW
inherit perl-module eutils
DESCRIPTION="Perl5 module for reading configuration files and parsing command line arguments."
-SRC_URI="mirror://cpan/authors/id/A/AB/ABW/${P}.tar.gz"
-HOMEPAGE="http://search.cpan.org/~abw/"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE=""
-PATCHES="${FILESDIR}/blockdiffs.patch"
-SRC_TEST="do"
+DEPEND=">=dev-perl/File-HomeDir-0.57"
+RDEPEND="${DEPEND}"
-DEPEND=">=dev-perl/File-HomeDir-0.57
- virtual/perl-Test-Simple
- dev-lang/perl"
+PATCHES=( "${FILESDIR}/blockdiffs.patch" )
+SRC_TEST="do"
diff --git a/dev-perl/AppConfig/ChangeLog b/dev-perl/AppConfig/ChangeLog
index 00661d367e22..b0264bd52cfe 100644
--- a/dev-perl/AppConfig/ChangeLog
+++ b/dev-perl/AppConfig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/AppConfig
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/ChangeLog,v 1.62 2009/05/02 12:07:34 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/ChangeLog,v 1.63 2009/08/16 08:13:24 tove Exp $
+
+ 16 Aug 2009; Torsten Veller <tove@gentoo.org> AppConfig-1.66.ebuild,
+ -files/blocksep.patch, -files/blockwhitespace.patch:
+ Cleanup. Remove old patch
02 May 2009; Torsten Veller <tove@gentoo.org> -AppConfig-1.56-r2.ebuild:
Cleanup
diff --git a/dev-perl/AppConfig/files/blocksep.patch b/dev-perl/AppConfig/files/blocksep.patch
deleted file mode 100644
index b9affd8a7211..000000000000
--- a/dev-perl/AppConfig/files/blocksep.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff -burN AppConfig-1.56.orig/lib/AppConfig/File.pm AppConfig-1.56/lib/AppConfig/File.pm
---- AppConfig-1.56.orig/lib/AppConfig/File.pm 2004-02-04 02:28:28.000000000 -0800
-+++ AppConfig-1.56/lib/AppConfig/File.pm 2004-05-28 15:08:31.432761817 -0700
-@@ -44,6 +44,7 @@
- STATE => $state, # AppConfig::State ref
- DEBUG => $state->_debug(), # store local copy of debug
- PEDANTIC => $state->_pedantic, # and pedantic flags
-+ BLOCKSEP => $state->_blocksep, # and block separator
- };
-
- bless $self, $class;
-@@ -87,7 +88,7 @@
- my $flag;
-
- # take a local copy of the state to avoid much hash dereferencing
-- my ($state, $debug, $pedantic) = @$self{ qw( STATE DEBUG PEDANTIC ) };
-+ my ($state, $debug, $pedantic, $blocksep) = @$self{ qw( STATE DEBUG PEDANTIC BLOCKSEP ) };
-
- # we want to install a custom error handler into the AppConfig::State
- # which appends filename and line info to error messages and then
-@@ -201,7 +202,7 @@
- $flag = $1;
-
- # $variable gets any $prefix
-- $variable = $prefix . '_' . $variable
-+ $variable = $prefix . $blocksep . $variable
- if length $prefix;
-
- # if the variable doesn't exist, we call set() to give
-diff -burN AppConfig-1.56.orig/lib/AppConfig/State.pm AppConfig-1.56/lib/AppConfig/State.pm
---- AppConfig-1.56.orig/lib/AppConfig/State.pm 2004-02-04 02:11:23.000000000 -0800
-+++ AppConfig-1.56/lib/AppConfig/State.pm 2004-05-28 14:42:23.588164697 -0700
-@@ -57,7 +57,7 @@
-
- # internal values that AUTOLOAD should provide access to
- my %METHFLAGS;
-- @METHFLAGS{ qw( PEDANTIC ) } = ();
-+ @METHFLAGS{ qw( PEDANTIC BLOCKSEP ) } = ();
-
- # variable attributes that may be specified in GLOBAL;
- my @GLOBAL_OK = qw( DEFAULT EXPAND VALIDATE ACTION ARGS ARGCOUNT );
-@@ -98,6 +98,7 @@
- PEDANTIC => 0, # return immediately on parse warnings
- EHANDLER => undef, # error handler (let's hope we don't need it!)
- ERROR => '', # error message
-+ BLOCKSEP => '_', # separator between [block] and variable name
- };
-
- bless $self, $class;
-@@ -509,8 +510,8 @@
- };
-
-
-- # CASE, CREATE and PEDANTIC are stored as they are
-- $opt =~ /^CASE|CREATE|PEDANTIC$/i && do {
-+ # CASE, CREATE, PEDANTIC and BLOCKSEP are stored as they are
-+ $opt =~ /^CASE|CREATE|PEDANTIC|BLOCKSEP$/i && do {
- $self->{ uc $opt } = $cfg->{ $opt };
- next;
- };
-@@ -1020,6 +1021,13 @@
- DEBUG (and also PEDANTIC) values of the state at that time. Subsequent
- changes to the AppConfig::State debug value will not affect them.
-
-+=item BLOCKSEP
-+
-+When parsing configuration files that are grouped using constructions
-+like [block], this string parameter determines what is used to
-+separate the name of the block from the name of each variable
-+contained within it. If unspecified, BLOCKSEP defaults to '_'.
-+
- =item GLOBAL
-
- The GLOBAL option allows default values to be set for the DEFAULT, ARGCOUNT,
diff --git a/dev-perl/AppConfig/files/blockwhitespace.patch b/dev-perl/AppConfig/files/blockwhitespace.patch
deleted file mode 100644
index 8fe839ecf3b6..000000000000
--- a/dev-perl/AppConfig/files/blockwhitespace.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -burN AppConfig-1.56.orig/lib/AppConfig/File.pm AppConfig-1.56/lib/AppConfig/File.pm
---- AppConfig-1.56.orig/lib/AppConfig/File.pm 2004-02-04 02:28:28.000000000 -0800
-+++ AppConfig-1.56/lib/AppConfig/File.pm 2004-05-26 15:54:17.854304993 -0700
-@@ -170,7 +170,7 @@
- s/\s+$//;
-
- # look for a [block] to set $prefix
-- if (/^\[([^\]]+)\]$/) {
-+ if (/^\[\s*([^\]\s]+)\s*\]$/) {
- $prefix = $1;
- print STDERR "Entering [$prefix] block\n" if $debug;
- next;