summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-10-23 19:54:14 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-10-23 19:54:14 +0000
commit63781e0e9b7845d4c1cbe2f64e13ad219eb39bbd (patch)
tree7cbc56b53ef6a5497e7bbe1826e08de98de94fe4 /dev-perl/HTML-Mason
parentStable on hppa (diff)
downloadgentoo-2-63781e0e9b7845d4c1cbe2f64e13ad219eb39bbd.tar.gz
gentoo-2-63781e0e9b7845d4c1cbe2f64e13ad219eb39bbd.tar.bz2
gentoo-2-63781e0e9b7845d4c1cbe2f64e13ad219eb39bbd.zip
Version bump
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.35.ebuild64
-rw-r--r--dev-perl/HTML-Mason/files/digest-HTML-Mason-1.353
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index e36a4b27fcbb..dbbb02ba2ae8 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.57 2006/10/21 14:14:01 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.58 2006/10/23 19:54:14 mcummings Exp $
+
+*HTML-Mason-1.35 (23 Oct 2006)
+
+ 23 Oct 2006; Michael Cummings <mcummings@gentoo.org>
+ +HTML-Mason-1.35.ebuild:
+ Version bump
21 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
HTML-Mason-1.33.ebuild:
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.35.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.35.ebuild
new file mode 100644
index 000000000000..b51744d685b3
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.35.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.35.ebuild,v 1.1 2006/10/23 19:54:14 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="apache2 modperl doc"
+SRC_TEST="do"
+
+DEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ !apache2? (
+ =net-www/apache-1*
+ >=www-apache/libapreq-1.0-r2
+ <www-apache/mod_perl-2 )
+ apache2? (
+ >=net-www/apache-2
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2 )
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/module-build-0.28
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-lang/perl"
+
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ if use apache2; then
+ APACHE="/usr/sbin/apache2"
+ else
+ APACHE="/usr/sbin/apache"
+ fi
+
+ APACHE="${APACHE}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}
+
+
diff --git a/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.35 b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.35
new file mode 100644
index 000000000000..35ba55058a3d
--- /dev/null
+++ b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.35
@@ -0,0 +1,3 @@
+MD5 c09f77e2af500b51d22e0238c0534994 HTML-Mason-1.35.tar.gz 386408
+RMD160 0782bc005b50d63beebc493d926505a1d735e4c5 HTML-Mason-1.35.tar.gz 386408
+SHA256 01c75ebc523b77b88d5754fa93a283eeff77bcf799536db8697b61daf42f36bd HTML-Mason-1.35.tar.gz 386408