summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-07-03 00:48:12 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-07-03 00:48:12 +0000
commitaf04f39089eae2f2b65885819e2b8a8ade910907 (patch)
tree1c83101d145abe6d81ac2f6aeeed7b71d85a797d /dev-perl/Inline/Inline-0.44-r1.ebuild
parentAddresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com> (diff)
downloadgentoo-2-af04f39089eae2f2b65885819e2b8a8ade910907.tar.gz
gentoo-2-af04f39089eae2f2b65885819e2b8a8ade910907.tar.bz2
gentoo-2-af04f39089eae2f2b65885819e2b8a8ade910907.zip
Addresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com>
Diffstat (limited to 'dev-perl/Inline/Inline-0.44-r1.ebuild')
-rw-r--r--dev-perl/Inline/Inline-0.44-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Inline/Inline-0.44-r1.ebuild b/dev-perl/Inline/Inline-0.44-r1.ebuild
new file mode 100644
index 000000000000..9354165ede71
--- /dev/null
+++ b/dev-perl/Inline/Inline-0.44-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/Inline-0.44-r1.ebuild,v 1.1 2003/07/03 00:48:09 mcummings Exp $
+
+inherit perl-module eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Write Perl subroutines in other languages"
+SRC_URI="http://www.cpan.org/authors/id/I/IN/INGY/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/doc/INGY/Inline-0.43/Inline.pod"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc alpha"
+
+DEPEND="${DEPEND}
+ dev-perl/Digest-MD5
+ dev-perl/File-Spec
+ dev-perl/Parse-RecDescent
+ dev-perl/Test-Harness"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ #gtk-2 suggested patch
+ if [ "`use gtk2`" ]
+ then
+ epatch ${FILESDIR}/gtk2-patch.diff
+ fi
+
+}
+
+src_compile() {
+
+ echo "y" | perl-module_src_compile
+ perl-module_src_test
+}
+
+
+src_install () {
+
+ perl-module_src_install
+ dohtml DT.html
+}