summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-05-08 16:53:50 +0000
committerRobert Coie <rac@gentoo.org>2003-05-08 16:53:50 +0000
commitb0a39732d969fcd9bd63cd9347cb1681381e1cdf (patch)
treed21977e41b06a0808d4bed7094f4959ffec3fcc6 /dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
parentmade selinux !!internal use only!! (diff)
downloadgentoo-2-b0a39732d969fcd9bd63cd9347cb1681381e1cdf.tar.gz
gentoo-2-b0a39732d969fcd9bd63cd9347cb1681381e1cdf.tar.bz2
gentoo-2-b0a39732d969fcd9bd63cd9347cb1681381e1cdf.zip
add header, address bug 16388
Diffstat (limited to 'dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild')
-rw-r--r--dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild b/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
index 67cb836911ee..aabe0a8016e9 100644
--- a/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
+++ b/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild
@@ -1,3 +1,7 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-RawIP/Net-RawIP-0.09d.ebuild,v 1.3 2003/05/08 16:53:46 rac Exp $
+
inherit perl-module
S=${WORKDIR}/${P}
@@ -10,3 +14,25 @@ DEPEND="net-libs/libpcap"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ # This patch makes sure CFLAGS are applied properly instead of
+ # being runon additions to the previously defined symbol.
+ # Attempts to address the problem in bug 16388 without completely
+ # losing CFLAGS. The patch submitted to that bug chose to remove
+ # the $ENV{'CFLAGS'}. With the current state of MakeMaker, this
+ # would be a perfectly acceptable choice, because the approach
+ # taken here ends up with two sets of CFLAGS in the compile line.
+ # However, I believe that it may be more prudent in the long run
+ # to try to accommodate what I think the original intention of the
+ # Makefile was. Perhaps on some system with some (maybe future)
+ # version of MakeMaker, this would be the only way to convey
+ # CFLAGS. Since duplication of CFLAGS is harmless, I'm going to
+ # go with adding the space instead of taking out the $ENV{CFLAGS}.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.08
+
+ sed -i -e "s/D_IFLIST_'\./D_IFLIST_ '\./" ${S}/Makefile.PL
+} \ No newline at end of file