summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-01-05 20:42:57 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-01-05 20:42:57 +0000
commitdc4248878e45349f39e1c55cd103fbe8a927e7c6 (patch)
tree4bc7ee960581b1ca398033f798f94eae38e4117b /dev-perl/POE/POE-0.99.17.ebuild
parentConvert to use elog. (diff)
downloadgentoo-2-dc4248878e45349f39e1c55cd103fbe8a927e7c6.tar.gz
gentoo-2-dc4248878e45349f39e1c55cd103fbe8a927e7c6.tar.bz2
gentoo-2-dc4248878e45349f39e1c55cd103fbe8a927e7c6.zip
Version bump
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'dev-perl/POE/POE-0.99.17.ebuild')
-rw-r--r--dev-perl/POE/POE-0.99.17.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/POE/POE-0.99.17.ebuild b/dev-perl/POE/POE-0.99.17.ebuild
new file mode 100644
index 000000000000..ca52dfe80659
--- /dev/null
+++ b/dev-perl/POE/POE-0.99.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/POE/POE-0.99.17.ebuild,v 1.1 2007/01/05 20:42:57 mcummings Exp $
+
+IUSE="ipv6 libwww ncurses tk"
+
+inherit versionator perl-module
+MY_P="${PN}-$(delete_version_separator 2)"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A framework for creating multitasking programs in Perl"
+HOMEPAGE="http://search.cpan.org/~rcaputo/${MY_P}/"
+SRC_URI="mirror://cpan/authors/id/R/RC/RCAPUTO/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="dev-perl/ExtUtils-AutoInstall
+ >=dev-perl/Event-1.00
+ >=virtual/perl-Time-HiRes-1.59
+ >=dev-perl/Compress-Zlib-1.33
+ >=virtual/perl-Storable-2.12
+ >=dev-perl/IO-Tty-1.02
+ perl-core/Filter
+ >=virtual/perl-File-Spec-0.87
+ >=virtual/perl-Test-Harness-2.26
+ dev-perl/FreezeThaw
+ >=virtual/perl-Test-Simple-0.54
+ >=dev-perl/TermReadKey-2.21
+ ipv6? ( >=dev-perl/Socket6-0.14 )
+ tk? ( >=dev-perl/perl-tk-800.027 )
+ libwww? ( >=dev-perl/libwww-perl-5.79
+ >=dev-perl/URI-1.30 )
+ ncurses? ( >=dev-perl/Curses-1.08 )
+ dev-lang/perl"
+
+mymake="/usr"
+