summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-06-28 17:17:03 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-06-28 17:17:03 +0000
commit1a10b50ebe39adb555eda9d50b41377a37933430 (patch)
tree690934667b8cd98a5b7fe677763fe7e5f3052f75 /dev-perl/Sys-Virt
parentLink against gmodule-2.0 libraries wrt #508988 by Gabriel Homeier and Ted Tan... (diff)
downloadgentoo-2-1a10b50ebe39adb555eda9d50b41377a37933430.tar.gz
gentoo-2-1a10b50ebe39adb555eda9d50b41377a37933430.tar.bz2
gentoo-2-1a10b50ebe39adb555eda9d50b41377a37933430.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl/Sys-Virt')
-rw-r--r--dev-perl/Sys-Virt/ChangeLog9
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-perl/Sys-Virt/ChangeLog b/dev-perl/Sys-Virt/ChangeLog
index 270ca7f9e66e..bce0ffaeb8a5 100644
--- a/dev-perl/Sys-Virt/ChangeLog
+++ b/dev-perl/Sys-Virt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Sys-Virt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/ChangeLog,v 1.24 2013/09/30 11:44:29 zlogene Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/ChangeLog,v 1.25 2014/06/28 17:17:03 zlogene Exp $
+
+*Sys-Virt-1.2.5 (28 Jun 2014)
+
+ 28 Jun 2014; Mikle Kolyada <zlogene@gentoo.org> +Sys-Virt-1.2.5.ebuild:
+ Version bump
*Sys-Virt-1.1.2 (30 Sep 2013)
diff --git a/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild b/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild
new file mode 100644
index 000000000000..c6bbd3635554
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild,v 1.1 2014/06/28 17:17:03 zlogene Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=DANBERR
+MODULE_VERSION=1.2.5
+inherit perl-module
+
+DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+SRC_TEST="do"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}