summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2013-03-17 15:51:56 +0000
committerTorsten Veller <tove@gentoo.org>2013-03-17 15:51:56 +0000
commitb2279201c1ff0301930d0c7689cc173d0c871938 (patch)
tree6f004dd71eb75ea0a876bb489e820cf7321c2a09 /dev-perl/libwww-perl
parentAdd proxy-maintainers to metadata.xml (diff)
downloadgentoo-2-b2279201c1ff0301930d0c7689cc173d0c871938.tar.gz
gentoo-2-b2279201c1ff0301930d0c7689cc173d0c871938.tar.bz2
gentoo-2-b2279201c1ff0301930d0c7689cc173d0c871938.zip
[bump] dev-perl/libwww-perl-6.50.0
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index e5222805e689..aa54192c3a74 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.163 2013/02/19 02:28:11 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.164 2013/03/17 15:51:56 tove Exp $
+
+*libwww-perl-6.50.0 (17 Mar 2013)
+
+ 17 Mar 2013; Torsten Veller <tove@gentoo.org> +libwww-perl-6.50.0.ebuild:
+ Version bump
19 Feb 2013; Zac Medico <zmedico@gentoo.org> libwww-perl-6.40.0.ebuild:
Add ~arm-linux keyword.
diff --git a/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild
new file mode 100644
index 000000000000..000911cdc1cf
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-6.50.0.ebuild,v 1.1 2013/03/17 15:51:56 tove Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=6.05
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-perl/File-Listing-6.0.0
+ >=dev-perl/HTTP-Cookies-6.0.0
+ >=dev-perl/HTTP-Daemon-6.0.0
+ >=dev-perl/HTTP-Date-6.0.0
+ >=dev-perl/HTTP-Negotiate-6.0.0
+ >=dev-perl/HTTP-Message-6.0.0
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=dev-perl/Net-HTTP-6.40.0
+ >=dev-perl/WWW-RobotRules-6.0.0
+ >=virtual/perl-Digest-MD5-2.120.0
+ dev-perl/Encode-Locale
+ >=dev-perl/HTML-Parser-3.340.0
+ >=virtual/perl-MIME-Base64-2.120.0
+ virtual/perl-libnet
+ >=dev-perl/URI-1.100.0
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ ssl? (
+ dev-perl/LWP-Protocol-https
+ )
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do