summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-09-28 19:23:44 +0000
committerRobert Coie <rac@gentoo.org>2004-09-28 19:23:44 +0000
commit2f210e3917f38b16fbc2381917f4d9082ece6f57 (patch)
tree4a228640d719a305d4b1a6f9e5546530bafd58c6 /dev-perl/mod_perl
parentpie executables will have runtime text relocations in them with zip unless we... (diff)
downloadgentoo-2-2f210e3917f38b16fbc2381917f4d9082ece6f57.tar.gz
gentoo-2-2f210e3917f38b16fbc2381917f4d9082ece6f57.tar.bz2
gentoo-2-2f210e3917f38b16fbc2381917f4d9082ece6f57.zip
1.99.16, masked
Diffstat (limited to 'dev-perl/mod_perl')
-rw-r--r--dev-perl/mod_perl/ChangeLog8
-rw-r--r--dev-perl/mod_perl/files/digest-mod_perl-1.99.161
-rw-r--r--dev-perl/mod_perl/files/mod_perl-1.99.16-sneak-tmpdir.patch11
-rw-r--r--dev-perl/mod_perl/mod_perl-1.99.16.ebuild121
4 files changed, 140 insertions, 1 deletions
diff --git a/dev-perl/mod_perl/ChangeLog b/dev-perl/mod_perl/ChangeLog
index dc8a06b66e59..f3919f36c54d 100644
--- a/dev-perl/mod_perl/ChangeLog
+++ b/dev-perl/mod_perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/mod_perl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/ChangeLog,v 1.42 2004/09/21 13:44:28 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/ChangeLog,v 1.43 2004/09/28 19:23:44 rac Exp $
+
+*mod_perl-1.99.16 (28 Sep 2004)
+
+ 28 Sep 2004; Robert Coie <rac@gentoo.org>
+ +files/mod_perl-1.99.16-sneak-tmpdir.patch, +mod_perl-1.99.16.ebuild:
+ New upstream, maketest has some inconsistent problems, reliability suspect
21 Sep 2004; Michael Cummings <mcummings@gentoo.org>
+files/mod_perl-1.29-ipv6.patch:
diff --git a/dev-perl/mod_perl/files/digest-mod_perl-1.99.16 b/dev-perl/mod_perl/files/digest-mod_perl-1.99.16
new file mode 100644
index 000000000000..e2aa17a19fc2
--- /dev/null
+++ b/dev-perl/mod_perl/files/digest-mod_perl-1.99.16
@@ -0,0 +1 @@
+MD5 94da0f0301e127e8ef8cf77f7c11b1b4 mod_perl-1.99_16.tar.gz 1352516
diff --git a/dev-perl/mod_perl/files/mod_perl-1.99.16-sneak-tmpdir.patch b/dev-perl/mod_perl/files/mod_perl-1.99.16-sneak-tmpdir.patch
new file mode 100644
index 000000000000..a2fb226ed323
--- /dev/null
+++ b/dev-perl/mod_perl/files/mod_perl-1.99.16-sneak-tmpdir.patch
@@ -0,0 +1,11 @@
+--- t/conf/modperl_extra.pl.orig 2004-09-23 21:56:23.443749414 -0700
++++ t/conf/modperl_extra.pl 2004-09-23 21:55:22.149258138 -0700
+@@ -52,6 +52,8 @@
+
+ #see t/response/TestModperl/env.pm
+ $ENV{MODPERL_EXTRA_PL} = __FILE__;
++$ENV{TMPDIR} = __FILE__;
++$ENV{TMPDIR} =~ s,/work/.*,/temp,;
+
+ my $ap_mods = scalar grep { /^Apache/ } keys %INC;
+ my $apr_mods = scalar grep { /^APR/ } keys %INC;
diff --git a/dev-perl/mod_perl/mod_perl-1.99.16.ebuild b/dev-perl/mod_perl/mod_perl-1.99.16.ebuild
new file mode 100644
index 000000000000..53fc74d62360
--- /dev/null
+++ b/dev-perl/mod_perl/mod_perl-1.99.16.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.99.16.ebuild,v 1.1 2004/09/28 19:23:44 rac Exp $
+
+inherit eutils
+
+front=${PV%\.*}
+back=\_${PV##*\.}
+MY_PV=${PV:0:${#front}}${back}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An embedded Perl interpreter for Apache2"
+SRC_URI="http://perl.apache.org/dist/${MY_P}.tar.gz"
+HOMEPAGE="http://perl.apache.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~alpha ~ia64 ~sparc ~ppc"
+IUSE=""
+SLOT="1"
+
+# see bug 30087 for why sudo is in here
+
+DEPEND="dev-lang/perl
+ =net-www/apache-2*
+ >=dev-perl/CGI-2.93
+ >=sys-apps/sed-4
+ app-admin/sudo"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # I am not entirely happy with this solution, but here's what's
+ # going on here if someone wants to take a stab at another
+ # approach. When userpriv compilation is off, then the make
+ # process drops to user "nobody" to run the test servers. This
+ # server is closed, and then the socket is rebound using
+ # SO_REUSEADDR. If the same user does this, there is no problem,
+ # and the socket may be rebound immediately. If a different user
+ # (yes, in my testing, even root) attempts to rebind, it fails.
+ # Since the "is the socket available yet" code and the
+ # second-batch bind call both run as root, this will fail.
+
+ # The upstream settings on my test machine cause the second batch
+ # of tests to fail, believing the socket to still be in use. I
+ # tried patching various parts to make them run as the user
+ # specified in $config->{vars}{user} using getpwnam, but found
+ # this patch to be fairly intrusive, because the userid must be
+ # restored and the patch must be applied to multiple places.
+
+ # For now, we will simply extend the timeout in hopes that in the
+ # non-userpriv case, the socket will clear from the kernel tables
+ # normally, and the tests will proceed.
+
+ # If anybody is still having problems, then commenting out "make
+ # test" below should allow the software to build properly.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.06
+
+ sed -i -e "s/sleep \$_/sleep \$_ << 2/" ${S}/Apache-Test/lib/Apache/TestServer.pm || die "problem editing TestServer.pm"
+
+ # i wonder if this is the same sandbox issue, but TMPDIR is not
+ # getting through via SetEnv. sneak it through here.
+
+ epatch ${FILESDIR}/${P}-sneak-tmpdir.patch
+}
+
+src_compile() {
+ perl Makefile.PL \
+ PREFIX=${D}/usr \
+ MP_TRACE=1 \
+ MP_DEBUG=1 \
+ MP_USE_DSO=3 \
+ MP_INST_APACHE2=1 \
+ MP_APXS=/usr/sbin/apxs2 \
+ CCFLAGS="${CFLAGS} -fPIC" \
+ INSTALLDIRS=vendor </dev/null || die
+
+ # reported that parallel make is broken in bug 30257
+ emake -j1 || die
+
+ hasq maketest $FEATURES && src_test
+}
+
+src_test() {
+ # make test notes whether it is running as root, and drops
+ # privileges all the way to "nobody" if so, so we must adjust
+ # write permissions accordingly in this case.
+
+ if [ "`id -u`" == '0' ]; then
+ chown nobody:nobody ${WORKDIR}
+ chown nobody:nobody ${T}
+ fi
+
+ # this does not || die because of bug 21325. kudos to smark for
+ # the idea of setting HOME.
+
+ HOME="${T}/" make test
+}
+
+src_install() {
+ dodir /usr/lib/apache2-extramodules
+ make install \
+ MODPERL_AP_LIBEXECDIR=${D}/usr/lib/apache2-extramodules \
+ MODPERL_AP_INCLUDEDIR=${D}/usr/include/apache2 \
+ MP_INST_APACHE2=1 \
+ INSTALLDIRS=vendor || die
+
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/75_mod_perl.conf \
+ ${FILESDIR}/apache2-mod_perl-startup.pl
+
+ # take this out once all <15 versions are out of the tree
+ sed -i -e 's/Apache::Server /Apache::ServerRec /' ${D}/etc/apache2/conf/modules.d/apache2-mod_perl-startup.pl
+
+ dodoc ${FILESDIR}/75_mod_perl.conf Changes \
+ INSTALL LICENSE README STATUS
+ cp -a docs ${D}/usr/share/doc/${PF}
+ cp -a todo ${D}/usr/share/doc/${PF}
+}