summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-11-22 17:37:09 +0000
committerTorsten Veller <tove@gentoo.org>2010-11-22 17:37:09 +0000
commit3acbf20fedacb81b01e3e8d588b2acc4943418a4 (patch)
tree6320f1ac68858145fddff2e88605e76b548910ae /dev-perl
parentVersion bump (diff)
downloadgentoo-2-3acbf20fedacb81b01e3e8d588b2acc4943418a4.tar.gz
gentoo-2-3acbf20fedacb81b01e3e8d588b2acc4943418a4.tar.bz2
gentoo-2-3acbf20fedacb81b01e3e8d588b2acc4943418a4.zip
Version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog7
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.17.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index a110316ff7ed..7408bcedc9ac 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.84 2010/11/13 19:32:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.85 2010/11/22 17:37:09 tove Exp $
+
+*DBD-Pg-2.17.2 (22 Nov 2010)
+
+ 22 Nov 2010; Torsten Veller <tove@gentoo.org> +DBD-Pg-2.17.2.ebuild:
+ Version bump
13 Nov 2010; Raúl Porcel <armin76@gentoo.org> DBD-Pg-2.17.1-r1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #341865
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.17.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.17.2.ebuild
new file mode 100644
index 000000000000..e34fedb4a213
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.17.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.17.2.ebuild,v 1.1 2010/11/22 17:37:09 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}