summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-09-28 19:38:35 +0000
committerRobert Coie <rac@gentoo.org>2004-09-28 19:38:35 +0000
commitc10e504bfbd45797f9b00d3882c4cb78fae4706e (patch)
tree976710e59b488a46e0705376a558ee4fd5a6d494 /dev-perl
parentEbuild cleanup. Added to ~sparc. Stable on amd64 and x86. (Manifest recommit) (diff)
downloadgentoo-2-c10e504bfbd45797f9b00d3882c4cb78fae4706e.tar.gz
gentoo-2-c10e504bfbd45797f9b00d3882c4cb78fae4706e.tar.bz2
gentoo-2-c10e504bfbd45797f9b00d3882c4cb78fae4706e.zip
libapreq2, masked
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/libapreq2/ChangeLog11
-rw-r--r--dev-perl/libapreq2/files/digest-libapreq2-2.04.031
-rw-r--r--dev-perl/libapreq2/files/libapreq2-2.0-binloc.patch65
-rw-r--r--dev-perl/libapreq2/files/libapreq2-2.0-sandbox.patch33
-rw-r--r--dev-perl/libapreq2/libapreq2-2.04.03.ebuild92
-rw-r--r--dev-perl/libapreq2/metadata.xml10
6 files changed, 212 insertions, 0 deletions
diff --git a/dev-perl/libapreq2/ChangeLog b/dev-perl/libapreq2/ChangeLog
new file mode 100644
index 000000000000..af17756c7175
--- /dev/null
+++ b/dev-perl/libapreq2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-perl/libapreq2
+# Copyright 2003-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libapreq2/ChangeLog,v 1.1 2004/09/28 19:38:35 rac Exp $
+
+*libapreq2-2.04.03 (28 Sep 2004)
+
+ 28 Sep 2004; Robert Coie <rac@gentoo.org> +files/libapreq2-2.0-binloc.patch,
+ +files/libapreq2-2.0-sandbox.patch, +libapreq2-2.04.03.ebuild:
+ mod_perl 2 version of libapreq. tests are not perfect yet, and reliability is
+ suspect
+
diff --git a/dev-perl/libapreq2/files/digest-libapreq2-2.04.03 b/dev-perl/libapreq2/files/digest-libapreq2-2.04.03
new file mode 100644
index 000000000000..5dd9d5bc65bf
--- /dev/null
+++ b/dev-perl/libapreq2/files/digest-libapreq2-2.04.03
@@ -0,0 +1 @@
+MD5 1f5dd762c877b716f3774d502f575196 libapreq2-2.04_03-dev.tar.gz 592748
diff --git a/dev-perl/libapreq2/files/libapreq2-2.0-binloc.patch b/dev-perl/libapreq2/files/libapreq2-2.0-binloc.patch
new file mode 100644
index 000000000000..dc27ca383953
--- /dev/null
+++ b/dev-perl/libapreq2/files/libapreq2-2.0-binloc.patch
@@ -0,0 +1,65 @@
+diff -burN libapreq2-2.04-dev.orig/Makefile.PL libapreq2-2.04-dev/Makefile.PL
+--- libapreq2-2.04-dev.orig/Makefile.PL 2004-08-29 16:30:15.000000000 -0700
++++ libapreq2-2.04-dev/Makefile.PL 2004-09-27 23:40:29.184738303 -0700
+@@ -23,7 +23,7 @@
+ system(@args) == 0 or die "system @args failed: $?";
+ }
+ else {
+- my @opts = qw(with-apache2-apxs with-apache2-src
++ my @opts = qw(with-apache2-apxs with-apache2-src with-apache2-httpd
+ with-apr-config with-apu-config apxs);
+
+ my @flags = qw/enable-maintainer-mode enable-perl-glue disable-perl-glue/;
+diff -burN libapreq2-2.04-dev.orig/acinclude.m4 libapreq2-2.04-dev/acinclude.m4
+--- libapreq2-2.04-dev.orig/acinclude.m4 2004-09-27 23:33:48.000000000 -0700
++++ libapreq2-2.04-dev/acinclude.m4 2004-09-27 23:37:03.659353161 -0700
+@@ -12,6 +12,9 @@
+ AC_ARG_WITH(apache2-apxs,
+ AC_HELP_STRING([--with-apache2-apxs],[path to apache2's apxs]),
+ [APACHE2_APXS=$withval],[APACHE2_APXS="apxs"])
++ AC_ARG_WITH(apache2-httpd,
++ AC_HELP_STRING([--with-apache2-httpd],[path to apache2 httpd binary]),
++ [APACHE2_HTTPD=$withval],[APACHE2_HTTPD=""])
+ AC_ARG_WITH(apache2-src,
+ AC_HELP_STRING([--with-apache2-src],[path to httpd-2 source]),
+ [APACHE2_SRC=$withval],[APACHE2_SRC=""])
+@@ -25,7 +28,9 @@
+ AC_MSG_ERROR([invalid Apache2 source directory]))
+
+ APACHE2_INCLUDES=-I$APACHE2_SRC/include
++ if test -z "${APACHE2_HTTPD}"; then
+ APACHE2_HTTPD=$APACHE2_SRC/httpd
++ fi
+ AC_ARG_WITH(apr-config,
+ AC_HELP_STRING([ --with-apr-config],[path to apr-config (requires --with-apache2-src)]),
+ [APR_CONFIG=$withval],[APR_CONFIG="$APACHE2_SRC/srclib/apr/apr-config"])
+@@ -35,7 +40,9 @@
+
+ else
+ APACHE2_INCLUDES=-I`$APACHE2_APXS -q INCLUDEDIR`
++ if test -z "${APACHE2_HTTPD}"; then
+ APACHE2_HTTPD=`$APACHE2_APXS -q SBINDIR`/httpd
++ fi
+ APR_MAJOR_VERSION=`$APACHE2_APXS -q APR_VERSION | cut -d. -f 1`
+ if test ${APR_MAJOR_VERSION:=0} -eq 0; then
+ APR_CONFIG=apr-config
+@@ -47,6 +54,7 @@
+ APR_CONFIG=`$APACHE2_APXS -q APR_BINDIR`/$APR_CONFIG
+ APU_CONFIG=`$APACHE2_APXS -q APU_BINDIR`/$APU_CONFIG
+
++ echo "checking with $APACHE2_HTTPD"
+ if test -z "`$prereq_check apache2 $APACHE2_HTTPD`"; then
+ AC_MSG_ERROR([Bad apache2 version])
+ fi
+diff -burN libapreq2-2.04-dev.orig/glue/Makefile.am libapreq2-2.04-dev/glue/Makefile.am
+--- libapreq2-2.04-dev.orig/glue/Makefile.am 2004-06-21 15:19:10.000000000 -0700
++++ libapreq2-2.04-dev/glue/Makefile.am 2004-09-28 00:00:08.547277068 -0700
+@@ -6,7 +6,7 @@
+ cd perl; @PERL@ ../../build/xsbuilder.pl run
+
+ perl/Makefile: perl/xsbuilder perl/Makefile.PL
+- cd perl; @PERL@ Makefile.PL -apxs @APACHE2_APXS@
++ cd perl; @PERL@ Makefile.PL INSTALLDIRS=vendor -apxs @APACHE2_APXS@
+
+ perl_glue: perl/Makefile
+ cd perl; $(MAKE)
diff --git a/dev-perl/libapreq2/files/libapreq2-2.0-sandbox.patch b/dev-perl/libapreq2/files/libapreq2-2.0-sandbox.patch
new file mode 100644
index 000000000000..309cfc56c8a3
--- /dev/null
+++ b/dev-perl/libapreq2/files/libapreq2-2.0-sandbox.patch
@@ -0,0 +1,33 @@
+*** env/Makefile.am.orig Fri Nov 7 10:55:14 2003
+--- env/Makefile.am Mon Apr 5 17:41:46 2004
+***************
+*** 3,8 ****
+--- 3,12 ----
+ TEST_CONFIG_SCRIPT = package Apache::TestMM; filter_args(); generate_script("t/TEST")
+ EXTRA_DIST = t c-modules
+
++ INSTDSO = $(shell $(APR_CONFIG) --installbuilddir)/instdso.sh
++ SHLIBTOOL = $(shell $(APR_CONFIG) --installbuilddir)/libtool
++ APACHE2MODS = /usr/lib/apache2/extramodules
++
+ check_PROGRAMS = test_cgi
+
+ if BUILD_HTTPD
+***************
+*** 31,37 ****
+ mod_apreq_la_LDFLAGS = -export-dynamic -module -avoid-version -rpath $(APACHE2_MODULES)
+
+ install-exec-local: mod_apreq.la
+! @APACHE2_APXS@ -i -a -n apreq mod_apreq.la
+
+ t/TEST : Makefile.am t/TEST.PL
+ @PERL@ -MApache::TestMM -e '$(TEST_CONFIG_SCRIPT)' -- -apxs @APACHE2_APXS@
+--- 35,42 ----
+ mod_apreq_la_LDFLAGS = -export-dynamic -module -avoid-version -rpath $(APACHE2_MODULES)
+
+ install-exec-local: mod_apreq.la
+! mkdir -p $(DESTDIR)$(APACHE2MODS)
+! $(INSTDSO) SH_LIBTOOL=$(SHLIBTOOL) mod_apreq.la $(DESTDIR)$(APACHE2MODS)
+
+ t/TEST : Makefile.am t/TEST.PL
+ @PERL@ -MApache::TestMM -e '$(TEST_CONFIG_SCRIPT)' -- -apxs @APACHE2_APXS@
diff --git a/dev-perl/libapreq2/libapreq2-2.04.03.ebuild b/dev-perl/libapreq2/libapreq2-2.04.03.ebuild
new file mode 100644
index 000000000000..563a4c2ee4f7
--- /dev/null
+++ b/dev-perl/libapreq2/libapreq2-2.04.03.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libapreq2/libapreq2-2.04.03.ebuild,v 1.1 2004/09/28 19:38:35 rac Exp $
+
+inherit libtool eutils flag-o-matic
+MY_P=${P/alpha/}
+S=${WORKDIR}/${MY_P%%.[0-9][0-9]}-dev
+DESCRIPTION="A Apache Request Perl Module"
+MY_SRCBALL=${MY_P%.*}_${MY_P##*.}-dev.tar.gz
+SRC_URI="http://www.apache.org/dist/httpd/libapreq/${MY_SRCBALL}"
+HOMEPAGE="http://httpd.apache.org/apreq/"
+SLOT="2"
+LICENSE="Apache-1.1 as-is"
+KEYWORDS="~x86 ~amd64"
+
+# the 5.8.4 dep is to ensure Test-More and MakeMaker
+
+DEPEND="${DEPEND}
+ >=dev-lang/perl-5.8.4
+ >=sys-apps/sed-4
+ dev-perl/Apache-Test
+ >=net-www/apache-2.0.46
+ >=dev-perl/mod_perl-1.99
+ >=dev-perl/ExtUtils-XSBuilder-0.23"
+
+mydoc="TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-2.0-binloc.patch || die
+ epatch ${FILESDIR}/${PN}-2.0-sandbox.patch || die
+ echo "ScriptSock ${T}/run" >> ${S}/env/t/conf/extra.conf.in
+ echo "ScriptSock ${T}/run2" > ${S}/glue/perl/t/conf/extra.conf.in
+ elibtoolize --reverse-deps
+ sed -i -e 's/-apxs @APACHE2_APXS@/-apxs @APACHE2_APXS@ -user portage -group portage/' ${S}/env/Makefile.am
+ sed -i -e 's/-apxs @APACHE2_APXS@/-apxs @APACHE2_APXS@ -user portage -group portage -port 8549/' ${S}/glue/Makefile.am
+}
+
+src_compile() {
+
+ # the -i is for a missing depcomp
+ autoreconf -i -f
+
+ # the install process installs libapreq2 first, and then calls
+ # apxs2 -i, which tries to recompile a libtool thing and fails
+ # because it can't find libapreq2, which is still sitting in the
+ # staging directory. this approach thieved from subversion ebuild,
+ # suggested by pauldv. that didn't work, neither did the
+ # LD_LIBRARY_PATH thing. I'm at the end of my rope for now on
+ # this, so i'm disabling relink. Anybody that can figure out a
+ # cleaner way is certainly welcome to do so.
+
+ sed -i -e 's/need_relink=yes/#ouch need_relink=yes/' ${S}/ltmain.sh
+
+ # this may only be needed on 64-bit arches
+
+ append-flags -fPIC
+
+ econf --with-apache2-apxs=/usr/sbin/apxs2 \
+ --with-apache2-httpd=/usr/sbin/apache2 \
+ --enable-perl-glue
+
+ emake LT_LDFLAGS="-L${D}/usr/lib" || die
+
+ hasq maketest $FEATURES && src_test
+}
+
+src_test() {
+ # ccache breaks the cgi portion of make test
+ # thieved from lilypond ebuild
+ PATH="$(echo ":${PATH}:" | sed 's/:[^:]*ccache[^:]*:/:/;s/^://;s/:$//;')"
+
+ # even after all that, cgi.t can't find what it needs in its @INC.
+ # don't see how this ever ran for anybody. disabling for now
+ echo "cgi" > ${S}/env/t/SKIP
+ echo "cgi" > ${S}/glue/perl/t/SKIP
+
+ chown portage ${S}/..
+ chown portage ${S}
+ chown portage ${S}/env
+
+ # tests too flaky yet to || die
+
+ APACHE_TEST_NO_STICKY_PREFERENCES=1 HOME="${T}" emake test
+}
+
+src_install() {
+ emake -j1 DESTDIR=${D} LT_LDFLAGS="-L${D}/usr/lib" install || die
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/76_mod_apreq.conf
+}
diff --git a/dev-perl/libapreq2/metadata.xml b/dev-perl/libapreq2/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/dev-perl/libapreq2/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>