summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-03-29 00:26:38 +0000
committerStuart Herbert <stuart@gentoo.org>2004-03-29 00:26:38 +0000
commitec7388c491770b868072f8c97b0ceed89f547dd9 (patch)
tree9e4ca208a5e4a83ca6d5c36a9a96edee3a3e70b5 /dev-php/php-cgi/php-cgi-4.3.5.ebuild
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-ec7388c491770b868072f8c97b0ceed89f547dd9.tar.gz
gentoo-2-ec7388c491770b868072f8c97b0ceed89f547dd9.tar.bz2
gentoo-2-ec7388c491770b868072f8c97b0ceed89f547dd9.zip
Version bump
Diffstat (limited to 'dev-php/php-cgi/php-cgi-4.3.5.ebuild')
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/php-cgi/php-cgi-4.3.5.ebuild b/dev-php/php-cgi/php-cgi-4.3.5.ebuild
new file mode 100644
index 000000000000..ec5ad97ee54a
--- /dev/null
+++ b/dev-php/php-cgi/php-cgi-4.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.5.ebuild,v 1.1 2004/03/29 00:26:38 stuart Exp $
+
+PHPSAPI="cgi"
+inherit php-sapi eutils
+
+DESCRIPTION="PHP CGI"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+src_compile() {
+ # CLI needed to build stuff
+ myconf="${myconf} \
+ --enable-cgi \
+ --enable-cli \
+ --enable-fastcgi"
+
+ php-sapi_src_compile
+}
+
+
+src_install() {
+ PHP_INSTALLTARGETS="install"
+ php-sapi_src_install
+
+ # rename binary
+ mv ${D}/usr/bin/php ${D}/usr/bin/php-cgi
+}
+
+pkg_postinst() {
+ php-sapi_pkg_postinst
+ einfo "This is a CGI only build."
+}