summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2011-02-11 16:04:26 +0000
committerTom Knight <tomk@gentoo.org>2011-02-11 16:04:26 +0000
commit7a308714cd0f683a9895294719eff552c28baa8d (patch)
tree75c20e0f3d5b4d400899b74f811dff546412809d /dev-php/smarty
parentRevision bump to create a stable candidate with ree18 and without ruby19. (diff)
downloadgentoo-2-7a308714cd0f683a9895294719eff552c28baa8d.tar.gz
gentoo-2-7a308714cd0f683a9895294719eff552c28baa8d.tar.bz2
gentoo-2-7a308714cd0f683a9895294719eff552c28baa8d.zip
New revisions to support new file locations and changes to documentation
versioning scheme (Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/ChangeLog12
-rw-r--r--dev-php/smarty/metadata.xml5
-rw-r--r--dev-php/smarty/smarty-2.6.24-r1.ebuild (renamed from dev-php/smarty/smarty-2.6.26.ebuild)20
-rw-r--r--dev-php/smarty/smarty-2.6.26-r1.ebuild50
-rw-r--r--dev-php/smarty/smarty-3.0.6-r1.ebuild (renamed from dev-php/smarty/smarty-3.0.6.ebuild)16
5 files changed, 90 insertions, 13 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index feb5fc610edf..1e3a23774e39 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php/smarty
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.106 2011/02/08 11:40:46 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.107 2011/02/11 16:04:26 tomk Exp $
+
+*smarty-3.0.6-r1 (11 Feb 2011)
+*smarty-2.6.26-r1 (11 Feb 2011)
+*smarty-2.6.24-r1 (11 Feb 2011)
+
+ 11 Feb 2011; <tomk@gentoo.org> +smarty-2.6.24-r1.ebuild,
+ -smarty-2.6.26.ebuild, +smarty-2.6.26-r1.ebuild, -smarty-3.0.6.ebuild,
+ +smarty-3.0.6-r1.ebuild, metadata.xml:
+ New revisions to support new file locations and changes to documentation
+ versioning scheme
*smarty-3.0.6 (04 Feb 2011)
diff --git a/dev-php/smarty/metadata.xml b/dev-php/smarty/metadata.xml
index 463b3d5a03ed..f0c7227f6412 100644
--- a/dev-php/smarty/metadata.xml
+++ b/dev-php/smarty/metadata.xml
@@ -6,4 +6,9 @@
<email>tomk@gentoo.org</email>
<name>Tom Knight</name>
</maintainer>
+ <longdescription lang="en">
+ Smarty is a template engine for PHP, facilitating the separation of
+ presentation (HTML/CSS) from application logic. This implies that PHP
+ code is application logic, and is separated from the presentation.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-php/smarty/smarty-2.6.26.ebuild b/dev-php/smarty/smarty-2.6.24-r1.ebuild
index 3b0ecc422e5b..41eec3e495f9 100644
--- a/dev-php/smarty/smarty-2.6.26.ebuild
+++ b/dev-php/smarty/smarty-2.6.24-r1.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.26.ebuild,v 1.2 2011/01/06 13:10:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.24-r1.ebuild,v 1.1 2011/02/11 16:04:26 tomk Exp $
-inherit php-lib-r1 eutils
+inherit php-lib-r1 eutils versionator
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
MY_P="Smarty-${PV}"
+MAJOR_PV=$(get_version_component_range 1-2)
DESCRIPTION="A template engine for PHP."
HOMEPAGE="http://www.smarty.net/"
-SRC_URI="http://www.smarty.net/distributions/${MY_P}.tar.gz"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc"
-DEPEND=""
-RDEPEND=""
-PDEPEND="doc? ( dev-php/smarty-docs )"
+DEPEND=">=dev-lang/php-4.0.6"
+RDEPEND="${DEPEND}"
+PDEPEND="doc? ( =dev-php/smarty-docs-${MAJOR_PV} )"
S="${WORKDIR}/${MY_P}"
@@ -39,4 +40,11 @@ pkg_postinst() {
elog
elog "If you're upgrading from a previous version make sure to clear out your"
elog "templates_c and cache directories as some include paths have changed!"
+
+ if use doc; then
+ elog
+ elog "The versioning scheme for the smarty documentation has changed so installing"
+ elog "dev-php/smarty-docs-${MAJOR_PV} is not a downgrade despite what your package"
+ elog "manager might say."
+ fi
}
diff --git a/dev-php/smarty/smarty-2.6.26-r1.ebuild b/dev-php/smarty/smarty-2.6.26-r1.ebuild
new file mode 100644
index 000000000000..653314f90662
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.26-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.26-r1.ebuild,v 1.1 2011/02/11 16:04:26 tomk Exp $
+
+inherit php-lib-r1 eutils versionator
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+MAJOR_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-lang/php-4.0.6"
+RDEPEND="${DEPEND}"
+PDEPEND="doc? ( =dev-php/smarty-docs-${MAJOR_PV} )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is one of apache2-php5,"
+ elog "cgi-php5 or cli-php5)."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+
+ if use doc; then
+ elog
+ elog "The versioning scheme for the smarty documentation has changed so installing"
+ elog "dev-php/smarty-docs-${MAJOR_PV} is not a downgrade despite what your package"
+ elog "manager might say."
+ fi
+}
diff --git a/dev-php/smarty/smarty-3.0.6.ebuild b/dev-php/smarty/smarty-3.0.6-r1.ebuild
index 98e9cca69de7..df291f29f15b 100644
--- a/dev-php/smarty/smarty-3.0.6.ebuild
+++ b/dev-php/smarty/smarty-3.0.6-r1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.0.6.ebuild,v 1.1 2011/02/08 11:40:46 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.0.6-r1.ebuild,v 1.1 2011/02/11 16:04:26 tomk Exp $
-inherit php-lib-r1 eutils
+inherit php-lib-r1 eutils versionator
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
MY_P="Smarty-${PV}"
+MAJOR_PV=$(get_version_component_range 1-2)
DESCRIPTION="A template engine for PHP."
HOMEPAGE="http://www.smarty.net/"
@@ -16,15 +17,15 @@ SLOT="0"
IUSE="doc"
DEPEND=">=dev-lang/php-5.2"
-RDEPEND="$DEPEND"
-PDEPEND="doc? ( dev-php/smarty-docs )"
+RDEPEND="${DEPEND}"
+PDEPEND="doc? ( =dev-php/smarty-docs-${MAJOR_PV} )"
S="${WORKDIR}/${MY_P}"
need_php_by_category
src_install() {
- dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+ dodoc-php README SMARTY2_BC_NOTES
php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
}
@@ -34,9 +35,12 @@ pkg_postinst() {
elog "To use it in your scripts, either"
elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
- elog "php.ini file under /etc/php/SAPI (where SAPI is e.g apache2-php5.2,"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is e.g apache2-php5.3,"
elog "cgi-php5.3, etc)."
elog
elog "If you're upgrading from a previous version make sure to clear out your"
elog "templates_c and cache directories as some include paths have changed!"
+ elog
+ elog "If you are upgrading from smarty 2 you should read the SMARTY2_BC_NOTES file"
+ elog "in /usr/share/doc/${CATEGORY}/${PF}"
}