summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-09-04 16:51:27 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-09-04 16:51:27 +0000
commita9bb6fbbef9428aad01060d9f5040a2be63d3436 (patch)
tree9faf75f253846f58d2d04c1f6bb5c8ada40cf7d1 /dev-php/smarty
parentold (diff)
downloadgentoo-2-a9bb6fbbef9428aad01060d9f5040a2be63d3436.tar.gz
gentoo-2-a9bb6fbbef9428aad01060d9f5040a2be63d3436.tar.bz2
gentoo-2-a9bb6fbbef9428aad01060d9f5040a2be63d3436.zip
Version bump, #236187
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/ChangeLog8
-rw-r--r--dev-php/smarty/smarty-2.6.20.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index d0ed6506ecab..7bc2cfc974b1 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/smarty
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.80 2008/03/08 19:36:26 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.81 2008/09/04 16:51:27 dertobi123 Exp $
+
+*smarty-2.6.20 (04 Sep 2008)
+
+ 04 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +smarty-2.6.20.ebuild:
+ Version bump, #236187
08 Mar 2008; <pva@gentoo.org> smarty-2.6.19.ebuild:
amd64 stable, bug #212147.
diff --git a/dev-php/smarty/smarty-2.6.20.ebuild b/dev-php/smarty/smarty-2.6.20.ebuild
new file mode 100644
index 000000000000..fd1f541b33a9
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.20.ebuild,v 1.1 2008/09/04 16:51:27 dertobi123 Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( dev-php/smarty-docs )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is one of apache2-php5,"
+ elog "cgi-php5 or cli-php5)."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+}