summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2005-11-24 22:01:26 +0000
committerLuca Longinotti <chtekk@gentoo.org>2005-11-24 22:01:26 +0000
commit1f39808225ac7a667d708111960413144f950cbc (patch)
treedf9c88af2ce5121cd8a2f4e8e7c1255dc4e3ad3a /dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-1f39808225ac7a667d708111960413144f950cbc.tar.gz
gentoo-2-1f39808225ac7a667d708111960413144f950cbc.tar.bz2
gentoo-2-1f39808225ac7a667d708111960413144f950cbc.zip
Sync with overlay.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild')
-rw-r--r--dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild36
1 files changed, 26 insertions, 10 deletions
diff --git a/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild b/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
index 6f5f63121d87..f006c95ebd6b 100644
--- a/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
+++ b/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
@@ -1,25 +1,41 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild,v 1.2 2005/10/15 21:49:14 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild,v 1.3 2005/11/24 22:01:26 chtekk Exp $
-PHP_EXT_ZENDEXT="yes"
-PHP_EXT_PECL_PKG="apd"
PHP_EXT_NAME="apd"
PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
inherit php-ext-pecl-r1
-IUSE=""
+KEYWORDS="~sparc ~x86"
DESCRIPTION="A full-featured engine-level profiler/debugger."
-SLOT="0"
LICENSE="PHP"
-KEYWORDS="~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND} >=dev-php/PEAR-Console_Getopt-1.2-r1 !dev-php4/ZendOptimizer"
need_php_by_category
-src_install () {
- sed -i 's:/usr/local:/usr:g' ${S}/pprofp || die #83612
+pkg_setup() {
+ has_php
+
+ require_php_cli
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/fix-version-string-0.9.2.patch"
+}
+
+src_install() {
+ sed -i 's:/usr/local/bin/php:/usr/lib/php4/bin/php:g' "${S}/pprofp" || die "Unable to replace PHP path"
+ sed -i 's:pprofp:pprofp-php4:g' "${S}/pprofp" || die "Unable to replace PHP path"
php-ext-pecl-r1_src_install
- dobin pprofp
- dodoc LICENSE README
+ newbin pprofp pprofp-php4
+ dodoc-php LICENSE README
}